View Issue Details

IDProjectCategoryView StatusLast Update
0012701MediaMonkey (current)Synchronizationpublic2016-12-19 16:47
ReporterLudek 
PriorityimmediateSeveritymajorReproducibilityrandom
Status closedResolutionfixed 
Product Version4.1.6 
Target Version4.1.7Fixed in Version4.1.7 
Summary0012701: iOS 8.3 sync often fails (hangs)
DescriptionBased on feedback here http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=80503 and also based on my tests iOS8 sync often fails after upgrade to iOS 8.3

Based on my tests (iTouch 5) the first sync after MM restart is always successful, but then any (randomly 5th or 7th) sync fails and any subsequent sync fails too (unless MM is restarted).

Additional Information#KUH-172-32877, CTV-486-98648
TagsNo tags attached.
Fixed in build1739

Relationships

related to 0012678 resolvedLudek Lyrics not updated for existing track on iOS8 device 
related to 0012715 resolvedLudek iOS 8.3 sync is very slow for some users (and can crash on sync end) 
related to 0013784 resolvedLudek iOS10: Lyrics not shown in the Music app 

Activities

Ludek

2015-04-13 12:24

developer   ~0042419

Last edited: 2015-04-13 12:24

View 2 revisions

Further testing revealed that it is realted to particular files.

Right clicking a file and Send to -> iPhone always fail for some files while always work for others.
It seems to be something in the file metadata that the iOS 8.3 devices don't like.

Ludek

2015-04-13 14:01

developer   ~0042420

It hangs on songs with Lyrics, it is related to issue 0012678 , starting from iOS8 lyrics are not transferred via BPLISTs, but read from tag / looked up by iOS8 itself.

Ludek

2015-04-13 14:03

developer   ~0042421

Fixed in 4.1.7.1739

peke

2015-04-15 23:59

developer   ~0042433

Verified 1739 No regression on <v8 iOS devices

lowlander

2015-04-17 17:52

developer   ~0042445

User on forum reports it isn't resolved.

Exception EAccessViolation in module iTunesMobileDevice.dll at 663C9

Ludek

2015-04-21 13:05

developer   ~0042453

Waiting for feedback: http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=80503&start=15#p406653

peke

2015-04-21 19:28

developer   ~0042457

No regression on iOS <v8 devices Verified 1740

rusty

2015-04-24 18:14

administrator   ~0042471

Tagging as resolved since we've decided to release this fix and since no users have reported with logs to the contrary. Should users report back with details for a bug that we can fix, we can re-open.

Ludek

2015-04-28 08:31

developer   ~0042479

Last edited: 2015-04-28 08:33

View 2 revisions

The further issues experienced by some users (espacially slow sync times) are now tracked as 0012715

Closing this one...