View Issue Details

IDProjectCategoryView StatusLast Update
0012715MediaMonkey (current)Synchronizationpublic2015-06-02 21:45
ReporterLudek Assigned To 
PriorityimmediateSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product Version4.1.7 
Target Version4.1.8Fixed in Version4.1.8 
Summary0012715: iOS 8.3 sync is very slow for some users (and can crash on sync end)
DescriptionThere are reports of several users that iOS 8.3 sync is very slow,
reported here:
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=80503&start=15#p407055

User Zs4 also noticed that tracks are not deleted from the device by MM

 
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=12&t=80503&start=15#p407055
IPG-322-81402
JHP-476-37282
Tagstodoc
Fixed in build1745

Relationships

related to 0012701 closedLudek iOS 8.3 sync often fails (hangs) 

Activities

Ludek

2015-04-28 08:21

developer   ~0042478

Last edited: 2015-04-28 08:23

View 2 revisions

Waiting for more feedback, debug logs (as requested via the forum post)

Ludek

2015-05-05 13:03

developer   ~0042500

Fixed partially in 4.1.8.1742 , still solving some issues via ticket #IPG-322-81402 ...

Ludek

2015-05-06 15:20

developer   ~0042506

Last edited: 2015-05-06 15:24

View 2 revisions

There is also sync crash on sync end (iPhone 4S) + incomplete sync (ticket #IPG-322-81402)

Fixed in 4.1.8.1742

Ludek

2015-05-06 15:28

developer   ~0042507

Resolved for testing the fixes (various tweaks)

Ludek

2015-05-07 09:23

developer   ~0042509

Last edited: 2015-05-07 09:26

View 4 revisions

Re-opened, based on the feedback from the user ticket #IPG-322-81402 the slowdowns still exist (device is getting slower and slower to reply during sync), so far it seems to be related to iPhone 4S models runnning iOS 8.3

I am going to get an iPhone 4S to test (no issues on iTouch 5)

Ludek

2015-05-12 10:51

developer   ~0042521

Last edited: 2015-05-12 11:06

View 3 revisions

User from ticket #IPG-322-81402 confirmed that prolonging "grappa data" communication timeout solved the sync issues for him, they performed several successful synces and indicated that 526 songs synced/copied in 30 minutes. Still quite slow, but faster than before and mainly synced successfully.

Incorporated the fix into build 4.1.8.1743

peke

2015-05-14 10:53

developer   ~0042535

No regresson found on Older iOS devices Verified 1743

Ludek

2015-05-17 12:45

developer   ~0042541

Last edited: 2015-05-17 12:49

View 3 revisions

Some users reported that there is AV in iTunesMobileDevice.dll and iPhone is not recognized.

They indicated that iTunes re-install solved the issue:
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=80503&sid=346d0a292c578a0dafed62cd0004b4a1&p=408128#p408202

User rabiatorDLX indicated that fresh reboot of both PC and iPhone solved the slow sync issue for him.

We should probably cover it by KB article.

Ludek

2015-05-19 22:44

developer   ~0042549

Last edited: 2015-05-19 22:45

View 2 revisions

User from ticket #JHP-476-37282 observed a crash with assertion in MediaMonkey64Helper.exe "Unknown Function: AFCFileRefWren"

Fixed in build 4.1.8.1745

peke

2015-06-02 21:45

developer   ~0042587

Verified 1745 closing after KB Gets updated