View Issue Details

IDProjectCategoryView StatusLast Update
0012101MediaMonkey 4Synchronizationpublic2015-12-17 22:25
Reportermarek Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version4.1.10Fixed in Version4.1.10 
Summary0012101: Duplicate names of playlists fail to sync correctly
DescriptionMMW should use different paths for two different playlists with same name. Now it causes constraint exceptions in MMA DB.
Steps To Reproduce1. Create two playlists in MMW with same name
2. One has to be parent of the other
3. Sync via wifi - sync is never successfull
Additional Informationhttps://rink.hockeyapp.net/manage/apps/64672/app_versions/39/crash_reasons/15789408
TagsNo tags attached.
Fixed in build1773

Relationships

related to 0012985 closedLudek MediaMonkey 4 Duplicate names of playlists fail to show content correctly over DLNA 
parent of 0012986 closedLudek MediaMonkey 4 Sync list config broken in MMA 513 / MMW 1771 (regression) 
related to 0011813 closedrusty MediaMonkey for Android Playlists with duplicate filenames in different parts of the playlist hierarchy don't both sync 
related to 0012983 closedLudek MediaMonkey for Android Playlists synced prior to MMA install result in duplicates after WiFi sync 

Activities

Ludek

2014-07-08 10:16

developer   ~0040333

Last edited: 2014-07-08 10:56

View 4 revisions

The numbered suffix solution was added as part of 0005814:0038579 for playlists synced via USB, the same should be done in case of WiFi sync too.

But it should be done on MMA side, because MMW doesn't know MMA's playlists content during WiFi sync (unlike USB sync). That said a playlist with same M3U path can be already on the device and MMW doesn't know it. Note that we have already added GUID for playlists, so pairing playlists based on GUID is preferable whenever possible.

Ludek

2014-07-08 13:45

developer   ~0040336

Last edited: 2014-07-08 14:17

View 2 revisions

Based on further offline discussion with Marek, the numbered suffixes were added on MMW side in build 4.1.4.1709, but it need be tweaked on MMA side anyhow to ensure that M3U path will be always unique in all possible scenarios.

marek

2014-07-11 07:39

developer   ~0040340

We have agreed that it should be implemented on MMA side. It is implemented in build 288. The scenario described above works.

But there is still one big issue:
When two playlists have the same name and are on same level and have the same parent, their request command in upnp will be the same and MMW is not able to distinguish between them and always response DIDL with content of first playlist.

Example:

my hierarchy of playlists:
aaa Hierarchic
  aaa Hierarchic (1 track)
  aaa Hierarchic (2 tracks)

1. Request for playlist with 1 tracks:
0SyncList:DeviceID:afaaa0fa-a463-3ca4-9dc5-62193c2aecc2.0.461ba94f-5f93-468a-9ef1-3df7bc2f82d9\Playlists\aaa Hierarchic\aaa Hierarchic
2. Response has 1 track
3. Request for playlist with 2 tracks (but the request is the same):
0SyncList:DeviceID:afaaa0fa-a463-3ca4-9dc5-62193c2aecc2.0.461ba94f-5f93-468a-9ef1-3df7bc2f82d9\Playlists\aaa Hierarchic\aaa Hierarchic
4. Response has 1 track - INCORRECT

We have implemented GUIDs to identify playlists but we don't use them here. This should be changed.

rusty

2014-12-10 18:31

administrator   ~0041411

Last edited: 2014-12-12 17:01

View 3 revisions

Tested in MMA 352 / MMW 1723 and this issue remains (though no crash was observed).
- USB sync fails to copy one of the playlists (aaa Hierarchic 2 tracks)
- Wi-Fi sync copies duplicates of one of the playlists (i.e. 2 copies of aaa Hierarchic (2 tracks)

Note: the problem only occurs for 2 identically named playlists at the same level of the hierarchy.

Ludek

2015-11-30 16:14

developer   ~0043460

Fixed in 4.1.10.1771

Ludek

2015-12-02 13:08

developer   ~0043487

Last edited: 2015-12-02 13:14

View 2 revisions

In build 4.1.10.1771 it synces same named playlists on the same level correctly, but if you enable '[x] Delete other files and playlists' then MMW wants to delete the same named playlist

Fixed in 4.1.10.1772

Ludek

2015-12-03 10:48

developer   ~0043500

Last edited: 2015-12-03 11:10

View 2 revisions

There was actually another USB sync related regression caused by the changes in 1771
=>
Fixed in 1773

peke

2015-12-17 22:25

developer   ~0043705

Verified 1778