View Issue Details

IDProjectCategoryView StatusLast Update
0005814MediaMonkey (current)Synchronizationpublic2013-12-11 09:41
Reporteruser_chrisjj 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSXPOS Version-
Product Version 
Target VersionFixed in Version4.1 
Summary0005814: Same-named playlist causes loss upon sync
DescriptionIf I sync a playlist having the same name but in a different parent folder as one already synced, the old list is lost - the new list is given the same name on the device and hence overwrites the old.

(Tested with d_USBMass1.DLL.)

Suggested fix:
a) Ideally use folders on the device (device permitting) or add a numeric suffix to the playlist name, failing which
b) Skip clashing playlists, alerting the user.
Additional InformationReported at http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=33354&
TagsNo tags attached.
Fixed in build1676

Activities

Ludek

2010-07-02 23:04

developer   ~0020315

It probably would make sense to create the filename as
Playlist - Imported Playlists - ABBA - The Best.m3u
or
Playlist/Imported Playlists/ABBA/The Best.m3u
(based on the '[x] Organize Playlist using: [...]' settings)
for a playlist located in the tree as
Playlist -> Imported Playlists -> ABBA -> The Best

user_chrisjj

2011-04-13 09:59

updater   ~0024289

Last edited: 2011-04-13 15:01

View 2 revisions

> It probably would make sense to create the filename as
> Playlist - Imported Playlists - ABBA - The Best.m3u

I disagree, since that too could cause clashes because "-" is not reserved in playlist names.

> or Playlist/Imported Playlists/ABBA/The Best.m3u

That sounds good. Though I suggest it be optional, since it seems likely it is not compatible with all devices.

I suggest the best UI for this would be one like the existing "Sync tracks to:".

Ludek

2013-12-05 19:00

developer   ~0038516

Last edited: 2013-12-05 19:06

View 5 revisions

Raised priority to 'urgent', this issue becomes problematic also with relation to MMA sync and this: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=74436 Mark's request.

Ludek

2013-12-07 14:30

developer   ~0038579

Last edited: 2013-12-07 14:33

View 2 revisions

Fixed in build 1676.


If there are 3 playlists with name 'MyPlaylist' on the sync-list, then 3 different playlist filenames are used:
/Playlists/MyPlaylist.m3u
/Playlists/MyPlaylist_1.m3u
/Playlists/MyPlaylist_2.m3u

peke

2013-12-11 09:41

developer   ~0038688

Verified 1680