View Issue Details

IDProjectCategoryView StatusLast Update
0012986MediaMonkey 4Synchronizationpublic2015-12-17 22:25
Reporterrusty Assigned To 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.10 
Target Version4.1.10Fixed in Version4.1.10 
Summary0012986: Sync list config broken in MMA 513 / MMW 1771 (regression)
DescriptionWhen attempting to Wi-Fi sync an android device that has previously USB-synced with MMW, upon clicking the SD Card to choose the sync location and granting permission to connect to MMW, access fails. e.g.

1 Completely delete MMA, /MediaMonkey from Android and delete sync profiles in MMW.
2 Connect device to MMW and initiate USB sync
3 Install and run MMA
4 Access the sync configuration
--> The choose sync location dialog appears
5 Choose SD card as the sync location
--> The Choose location dialog in MMA briefly flashes and then re-appears
--> MMW pops up the 'Grant access' dialog
6 Click 'Yes' to grant access in MMW
7 Choose SD Card again in the Choose sync location dialog in MMA
--> MMW again pops up the 'Grant access' dialog
8 Grant access again in MMW
9 In MMA attempt to configure the sync profile and add playlists to the auto-sync list
--> Although the playlists can be browsed, any attempt to select or deselect a playlist results in a 'Unable to contact remote server' message. This is particularly strange since 'Sync Now' works (using the settings from the USB sync operation)!!

This bug prevents Wi-Fi sync testing (except for testing that doesn't change the sync profile).

MMA Debug log: U04CVB1S0A
MMW debug log is attached, though it contains unnecessary information at the beginning of the log. Towards the end you can see the initiation of the Wi-Fi sync connection.
TagsNo tags attached.
Fixed in build1772

Relationships

related to 0013004 closedLudek Access confirmation are shown for all storages, even only one is selected 
child of 0012101 closedLudek Duplicate names of playlists fail to sync correctly 
child of 0012985 closedLudek Duplicate names of playlists fail to show content correctly over DLNA 

Activities

rusty

2015-12-01 07:13

administrator  

bug_12986.LOG.zip (144,669 bytes)

Ludek

2015-12-01 12:39

developer   ~0043479

Last edited: 2015-12-01 13:23

View 6 revisions

Hmm, this seems to be my yeasterday's regression related to 0012101 and 0012985 where I needed to change DLNA presentation of playlist to by accessed by GUIDs path instead of names path and I forgot to test remote sync-list config from MMA :-/

I tested only DLNA/UPnP browsing and WiFi sync with sync-list configured in MMW.

Good catch Rusty!

The worse case is that I have already written DUnit test for this in the past, but I did not run it yesterday :-(
The test would catch it.

Ludek

2015-12-01 13:18

developer   ~0043480

Fixed in 1772

peke

2015-12-17 22:25

developer   ~0043706

Verified 1778