View Issue Details

IDProjectCategoryView StatusLast Update
0020759MMW 5Main Panelpublic2024-05-24 06:17
Reporterzvezdan Assigned To 
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Fixed in Version5.1 
Summary0020759: Inaccessible files are not displayed as such in popup panels
DescriptionEntire Library / Album Artist - Grid view: when I click on some artist the popup with albums appear, then when I select any album with the inaccessible files, they will be displayed as normal, not grayed.

It is like that with all popups in Grid view: Genres, Albums, ...
TagsNo tags attached.
Fixed in build3016

Activities

michal

2024-04-23 11:04

developer   ~0075212

Fixed in build 3016. Only note, that checking accessibility is demanding operation and cannot be done for all files in all lists, it would slow things down a lot sometimes. Accessibility is checked in 'Playing' list only. So the files which are to be played are checked and then displayed grayed, if not accessible, in popups too.

zvezdan

2024-04-23 11:50

updater   ~0075213

I am not sure that we understand each other. I am talking about files from inaccessible medias that are already added to the Library. Such files are all inaccessible simply because their drives are missing and you don't need to have them in Playing panel to check their accessibility.

I discussed already with Ludek about similar thing in 0019123 issue, back when even the main tracklist didn't have displayed inaccessible files. Since then all tracklists have such tracks displayed in gray, e.g. Organize files and one in my own script. I don't understand why those listviews in popups are not behaving like other tracklists. But, then again, even the playlist editor didn't display such files correctly, until you fixed it recently in 0020640.

michal

2024-04-23 13:09

developer   ~0075214

File can be inaccessible for several reasons, this state can change even while the program is running (connected/disconnected disk, renamed source folder, etc.). Now the list in popup should behave the same way as elsewhere - display grayed where it already knows, that the file is inaccessible. Even elsewhere files are not always grayed, sometimes it was not detected yet, that they are not accessible.

zvezdan

2024-04-23 13:55

updater   ~0075215

Yes, I understand the implications of that what are saying. It is fine if the lists in popups behave as others, even if the accessible state of some particular files is not displayed correctly in situations that you mentioned.

zvezdan

2024-05-23 23:29

updater   ~0075526

The inaccessible items are displayed fine in popups in 3021. You could close this issue.