View Issue Details

IDProjectCategoryView StatusLast Update
0019263MediaMonkey 5DB / Backuppublic2022-08-06 19:23
ReporterLudek Assigned To 
PriorityurgentSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019263: Possible "out of memory" crash during scanning
DescriptionUser from ticket # 4535 is observing crash during scanning his 1.6 TB audio library.
Analyzing his log and it ends with "out of memory" as there are 3219 images cached in memory for some reason (in total size > 2.8 GB).
i.e. there must be a bug related to scanning of artwork images causing memory leak during scan.

EDIT: The key to replicate the issue is using a view where all the newly scanned tracks are shown.
i.e. Workaround should be to start MM5 in a node that does not list all tracks (e.g. empty Playing) and then start scanning.
TagsNo tags attached.
Fixed in build2658

Activities

Ludek

2022-07-19 11:24

developer   ~0068857

Fixed in 5.0.4.2658

peke

2022-08-06 19:23

developer   ~0068983

Verified 2659

@Ludek THX for test hint.