View Issue Details

IDProjectCategoryView StatusLast Update
0019262MediaMonkey 5Main Panelpublic2022-09-23 16:36
Reporterjiri Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.4 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019262: Playing image doesn't change
Description1. Change the Preview window to 'Playing' mode.
2. Play an album that has an artwork assigned => Preview window properly shows the artwork.
3. Play another album that does _not_ have an artwork => Preview window keeps showing the previous artwork instead of being empty!
TagsNo tags attached.
Fixed in build2664

Relationships

related to 0019391 assignedpetr Menus hide immediately sometimes 

Activities

michal

2022-07-27 11:36

developer   ~0068932

I cannot reproduce. For me the artwork is always removed as expected. Do you still reproduce it? Could be related to some other step or setting, I did not find any.

rusty

2022-09-20 01:01

administrator   ~0069388

I'm unable to replicate as well.

jiri

2022-09-20 14:32

administrator   ~0069397

Can still reproduce with build 2663. Sent Michal a screencast, will work with him...

jiri

2022-09-21 13:05

administrator   ~0069434

After more testing, found to be caused by enabled Background Artwork search. To be investigated by Michal...

michal

2022-09-21 15:13

developer   ~0069444

Fixed in build 2664. Preview window now hides previous artwork, when new artwork does not arrive till 250ms. We do not hide it always to avoid blinking, but in this case artwork request was put to artwork search queue and Preview window contained previous artwork whole time.

jiri

2022-09-22 12:48

administrator   ~0069473

Don't fully understand why can it be done immediately, but seems to work reasonably well now.