View Issue Details

IDProjectCategoryView StatusLast Update
0019215MediaMonkey 5Generalpublic2022-06-24 22:11
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version5.0.4 
Summary0019215: Long Filenames fail to be managed
DescriptionLong Filenames fail to be managed, but if they are already in library then they play.

This fail:
- Browsing folders
- Analyze Volume
- Drag and Drop to player/Now Playing

Strange but locate moved/missing work.

NOTE: This is not regression as it also fail for MM4, but at one point tracks were normally scanned into library back in 2006
TagsNo tags attached.
Fixed in build

Relationships

related to 0019218 newpetr Drag and Drop: D&D from File Explorer do not work in some cases (Chromium) 
related to 0019100 resolvedLudek Replacement for oFileObj.GetFile('x').ShortPath needed 

Activities

michal

2022-06-23 14:43

developer   ~0068660

Last edited: 2022-06-23 14:44

View 2 revisions

I can browse long paths in MM5 without problems, analyze volume works for me (this was most probably regression fixed in 0019214). Only problem I see is dropping files from long path opened in Explorer. In this case Chromium sends us in OnDragEnter, that user is dragging HTML element or text, instead of file, so we do not recognize, it is in fact file. Assigned to Petr to analyze it more, it seems to be problem in Chromium.

michal

2022-06-23 14:45

developer   ~0068661

Related glitch - when user drags file from short path over NP list, then go to long path and drags file from long path, it allows dropping the file, but it drops the file from previous short path.

peke

2022-06-23 21:36

developer   ~0068667

Ok Browsing finally works works but after registry tweak Reverting this to Value 2 (It was set to 1) https://admx.help/?Category=SecurityBaseline&Policy=Microsoft.Policies.MSS::Pol_MSS_NtfsDisable8dot3NameCreation , but I used command "fsutil.exe behavior set disable8dot3 2" from registry "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem" key "NtfsDisable8dot3NameCreation" to 2

Also I have mage changes to Registry "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem" key "LongPathsEnabled" to 1 https://admx.help/?Category=Windows_10_2016&Policy=Microsoft.Policies.FileSys::LongPathsEnabled or in the Local Group Policy Editor (gpedit.msc), in the left-hand pane, drill down to Computer Configuration > Administrative Templates > System > Filesystem. On the right, find the “Enable win32 long paths”

peke

2022-06-23 22:37

developer   ~0068670

Last edited: 2022-06-23 22:38

View 2 revisions

Note: I retested with Latest build 2655 (internally requested) and Update WaveForm (Empty like @Michal you got in offline talk) Analyze also still fail like it was recorded in original video and LOG file ("Line 09443 | 16.36030197 | [10804] TStreamAccess.OpenRead() failed")

michal

2022-06-24 15:00

developer   ~0068674

Decoding fixed in build 2655 (next official). I cannot reproduce problem with waveform and decoding now, please retest. Drag&drop problem is Chromium bug, this is still opened.

peke

2022-06-24 21:24

developer   ~0068675

Verified 2655

- Browsing folders and Analyze Volume Verified as fixed on Both Sample files and my local/network files

- Drag and Drop to player/Now Playing moved to 0019218

peke

2022-06-24 21:24

developer   ~0068676

Verified 2655