View Issue Details

IDProjectCategoryView StatusLast Update
0019123MediaMonkey 5Main Panelpublic2022-06-27 12:15
Reporterzvezdan Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019123: Missing files should be with different color in the tracklist, as it is in MM4
DescriptionMissing files should be with different color in the tracklist, as it is in MM4. Or with different font style (e.g. italic). At least make it optional.
TagsNo tags attached.
Fixed in build2650

Activities

Ludek

2022-05-30 14:46

developer   ~0068330

Last edited: 2022-05-30 14:47

View 2 revisions

For me missing files (deadlinks) are in grey color like on the attached screenshot, but only after attempt to play them (this works same as in MM4 though).
So am I missing something or there is a difference against MM4?
image.png (76,666 bytes)   
image.png (76,666 bytes)   

Ludek

2022-05-30 14:50

developer   ~0068331

Last edited: 2022-05-30 14:51

View 2 revisions

OK, I have just found a difference. It's not for deadlinks, but for Audio CD in library that is not inserted in the drive:
image-2.png (86,323 bytes)   
image-2.png (86,323 bytes)   

zvezdan

2022-05-30 14:56

updater   ~0068332

Yes, I am talking about files in the main tracklist, but it is not only for Audio CDs. For example, if someone replace HDs.

You could saw it in my animated screenshot in another issue. Here is MM4 with one file in the Library that is missing. In fact, all files from the same drive are missing, but I had only that file in that test.
screenshot.21.png (24,439 bytes)   
screenshot.21.png (24,439 bytes)   

zvezdan

2022-05-30 15:19

updater   ~0068333

Since you mentioned missing files in the Playing list, I have another related suggestion. Let me know if I should open another issue for it.

If I drag&drop M3U file that has missing referenced media files into the Playing list, the missing files will be in the same color as other files until the program tries to play them. Winamp will display such files in different background color immediately when you drop M3U file into its Playlist.

I have used that option to quickly check M3U files for missing media files since I don't need to play all these files just to find out if any of them is missing.

Ludek

2022-05-30 15:20

developer   ~0068334

Yes, it is case for all inaccessible medias.

=> Fixed in 5.0.4.2650

zvezdan

2022-05-30 15:22

updater   ~0068335

How about my another suggestion?

Ludek

2022-06-27 12:14

developer   ~0068701

Yes, without trying to access them MM can't know whether they are playable and accessing files can take 20 or more seconds when files are located e.g. on NAS.
So this needs to be done in another background task.
i.e. feel free to enter this as separate issue.