View Issue Details

IDProjectCategoryView StatusLast Update
0019074MediaMonkey 5Syncpublic2022-05-14 00:39
Reporterlowlander Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.3 
Target Version5.0.3Fixed in Version5.0.3 
Summary0019074: Crash when restarting MediaMonkey during wifi Sync
DescriptionIf MediaMonkey is restarted (or updated) during a wifi Sync it will shortly after started.
Steps To Reproduce42940000

1 Start wifi Sync from MMA
2 Let wifi Sync get to downloading phase where actual files are downloading to device
3 Close MM5
4 Start MM5
5 Maybe needed, start playback
--> Crash

Only way to stop this is to turn off device running MMA. MMA keeps in Sync status, showing no progress, but also no failure to user.
TagsNo tags attached.
Fixed in build2625

Relationships

related to 0019075 closedLudek Background Processes running on close should be shown for wifi Sync 

Activities

Ludek

2022-05-12 11:02

developer   ~0068113

Last edited: 2022-05-12 11:14

View 4 revisions

Studing the log/code there already is a mechanism to rebuild sync list once MM5 is restarted in the middle of wi-fi sync with MMA, but there is only 30 seconds timeout and in the LowLander's case it by evidence taken longer => resulting in the crash.

EDIT: Small correction: The sync-list was successfuly rebuilt also in the LowLander's case in less than 30 seconds, but by evidence it included another set of files (probably because limited auto-playlists with random order), and MMA wanted to download a file that hasn't been on sync list any longer. Thus the crash.

Ludek

2022-05-12 11:13

developer   ~0068114

Last edited: 2022-05-12 11:19

View 2 revisions

Fixed in 5.0.3.2625

peke

2022-05-13 20:56

developer   ~0068139

Verified 2625

Unable to replicate on 25 restarts, sync cuts during sync.

Test Note: Tested restart if MM5, Network disconnect (cable pulled, WiFi Disable, Network adapter disable)

lowlander

2022-05-14 00:39

developer   ~0068143

Verified on 2625