View Issue Details

IDProjectCategoryView StatusLast Update
0018746MediaMonkey 5Podcastspublic2022-01-13 21:40
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.3 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018746: Podcast Episodes download as TXT instead of MP3
DescriptionSome Podcasts download the episodes as TXT files instead of MP3.

Samples:
http://www.bbc.co.uk/programmes/p02nrtvg/episodes/downloads.rss
https://podcasts.files.bbci.co.uk/p07h19zz.rss
http://www.bbc.co.uk/programmes/p002vsxs/episodes/downloads.rss
Steps To Reproduce1 Subscribe to http://www.bbc.co.uk/programmes/p02nrtvg/episodes/downloads.rss
2 Have MediaMonkey download an episode
3 Check downloaded episode
--> It's a TXT file instead of MP3 file
Additional InformationTicket 3533
TagsNo tags attached.
Fixed in build2601

Relationships

related to 0015614 closedLudek Podcasts: Episodes not downloaded in correct format 

Activities

Ludek

2022-01-12 19:47

developer   ~0066608

OK, this is because HEAD request to the given MP3 episode returns wrong Content-Type:
image.png (38,790 bytes)   
image.png (38,790 bytes)   

Ludek

2022-01-12 19:47

developer   ~0066609

To be workarounded...

Ludek

2022-01-12 20:02

developer   ~0066610

OK, the type actually was within the feed itself (issue 0015614), but the following unexpected enclosureLegacy element broken the extraction from the feed itself and therefore MM5 asked the HEAD request for content-type which resulted in plain/text
image-2.png (6,679 bytes)   
image-2.png (6,679 bytes)   

Ludek

2022-01-12 20:05

developer   ~0066611

Fixed in 2601

lowlander

2022-01-13 21:40

developer   ~0066616

Verified on 2601, but it required unsubscribing and then resubscribing to the Podcast to work.