View Issue Details

IDProjectCategoryView StatusLast Update
0018738MediaMonkey 5Playbackpublic2022-01-13 21:41
Reporterjiri Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.3 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018738: Some streams don't play
DescriptionI found http://tunein-icecast.mediaworks.nz/rock_128kbps that doesn't play in MM. While Play button indicates that playback proceeds, there's no sound. The stream works fine e.g. in WinAmp.
TagsNo tags attached.
Fixed in build2601

Relationships

related to 0011397 closedLudek MediaMonkey 4 Some podcasts save without file extension 

Activities

jiri

2022-01-07 07:32

administrator   ~0066561

Note that this isn't a regression, the situation in MM4 is the same.

peke

2022-01-07 12:06

developer   ~0066562

It is AAC+ Stream which in the past created issues.

Sent Log To Michal.

michal

2022-01-07 13:32

developer   ~0066563

The problem is, that the stream does not have extension, so it is not clear what input plugin can play it. in_wmp3 cannot, but does not recognize it and is still trying.
in_mfaudio can play it without problems.
I will analyze it more.

michal

2022-01-07 16:48

developer   ~0066566

So the main problem is, that when asking site for MIME type of the link it returns text/html for some reason, instead of audio/aacp. I have no idea why.

michal

2022-01-07 17:09

developer   ~0066567

Fixed in build 2601. The site does not support http head request for getting MIME type, improved workaround.

lowlander

2022-01-13 21:41

developer   ~0066617

Verified on 2601, the stream plays.