View Issue Details

IDProjectCategoryView StatusLast Update
0018724MediaMonkey 5Otherpublic2022-04-28 16:59
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.3Fixed in Version5.0.3 
Summary0018724: Regular build still outputs debug messages from some plugins
DescriptionCurrently the regular build (not compiled as debug) still outputs debug messages from plugins like d_WMDM.dll, d_iPod.dll, d_iPhone.dll, in_mfudio.dll, f_flac.dll etc. etc.

This is because the plugins are currently compiled as debug.
We should compile 'release' versions of these plugins to prevent from the unwanted debug ouput and also make this plugins little bit smaller this way.
TagsNo tags attached.
Fixed in build2614

Activities

michal

2022-01-05 14:36

developer   ~0066516

Fixed for input, output and format plugins.

Ludek

2022-01-07 19:46

developer   ~0066581

ok, device plugins ( d_WMDM.dll, d_iPod.dll, d_iPhone.dll) are still TODO, assigned to me to add the build batches

Ludek

2022-01-07 22:52

developer   ~0066584

Batches for device plugins added.

peke

2022-01-15 02:58

developer   ~0066631

Verified 2601

tested normal install and it looks like in_, out_, d_ and f_ plugins do not broadcast messages anymore.

Ludek

2022-04-01 11:40

developer   ~0067406

Last edited: 2022-04-01 11:43

View 3 revisions

Re-opened:
Tested https://www.mediamonkey.com/beta/MediaMonkey_5.0.3.2611.exe
and it still output messages from in_mfaudio, WASAPI, WMDM, iPod -- so something is still screwed up.

Ludek

2022-04-01 11:50

developer   ~0067407

Last edited: 2022-04-01 12:38

View 3 revisions

I've checked and although LibBuild_WMDM.bat generates the correct release versions of the plugin to
/svn/HTML5Monkey/SetupFiles/plugins-release/
these versions aren't used for some reason

Petr, please look into this.

petr

2022-04-01 19:48

developer   ~0067412

Fixed

peke

2022-04-06 00:31

developer   ~0067451

Verified 2612

Unable to notice debug msgs anymore.

Ludek

2022-04-06 16:17

developer   ~0067463

Last edited: 2022-04-06 16:21

View 3 revisions

I still see debug messages from the plugins on 2612 regular build install:

So it still does not use the versions from /svn/HTML5Monkey/SetupFiles/plugins-release/ !
image.png (86,218 bytes)   
image.png (86,218 bytes)   

Ludek

2022-04-06 18:33

developer   ~0067468

Last edited: 2022-04-07 11:33

View 2 revisions

It was shown that LibBuild_WMDM.bat was missing from SVN, added.

Assigned to Michal to eliminate the in_mfaudio messages and SAStream messages during playback.

michal

2022-04-07 11:54

developer   ~0067480

LibBuild_in_mfaudio.bat saves correct release version of mfaudio plugin to plugins-release folder, but it is not used for some reason, Petr please look at it, it seems, it still takes wrong versions of plugins sometimes.

petr

2022-04-12 08:05

developer   ~0067516

Fixed (issue in MSVC local installation)

Ludek

2022-04-28 16:59

developer   ~0067850

Last edited: 2022-04-28 16:59

View 2 revisions

Confirmed the fix in 2617, closing...