View Issue Details

IDProjectCategoryView StatusLast Update
0018478MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-11-06 18:29
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018478: Auto-tag: album art fails to save for some tracks
DescriptionBy default, MM is configured to save artwork to tags, if possible, however, when auto-tagging certain tracks, MM looks up the artwork but doesn't save it to the tag (it's saved as 'unsaved image'). e.g.

1 Scan track 'again & again'
2 In Locations > Path [List], select the track and initiate Auto-tag
--> AA is looked up, but the artwork flashes several times (this doesn't occur with other tracks)!
3 Click Tag & Continue to save the changes
4 Click Properties > Artwork
--> The artwork displays (it's a 640x640 196KB image) but the status is 'Unsaved image'!
5 Click the 'Save' button
--> Artwork saves to the tag as expected (as subsequently verified)

Note: if I attempt to lookup and save artwork manually, it saves to the tag as expected. The problem only occurs with Auto-tag!
TagsNo tags attached.
Fixed in build2516

Relationships

related to 0018050 closedpetr Can't add multiple Artworks using Browse from Lookup Image window / Add Cover disappears 

Activities

petr

2021-10-27 18:05

developer   ~0065531

Fixed

rusty

2021-10-29 20:52

administrator   ~0065580

There's something strange going on here. Now when the track is tagged, it's impossible to remove the artwork from Properties > Artwork! i.e. clicking the 'garbage can' icon has no effect!

This is really strange because it only occurs with some tracks (e.g. it'll occur for some m4a files but not others)?!

michal

2021-11-02 09:07

developer   ~0065634

Last edited: 2021-11-02 09:30

View 2 revisions

Can you analyze it more? For me and Petr it works, tried several files of several formats, artworks in tag and in folder, and they are removed as they should. Is it related only to some specific files or some exact steps? Do you reproduce it with another installation of MM5 and same files?

michal

2021-11-05 16:04

developer   ~0065754

Last edited: 2021-11-05 16:05

View 2 revisions

Fixed in build 2516. Problem was related to covers of newly scanned files, for such files editing of covers was buggy.

peke

2021-11-06 18:29

developer   ~0065781

Verified 2516

Inable to reproduce anymore