View Issue Details

IDProjectCategoryView StatusLast Update
0018410MediaMonkey 5UPnP / DLNApublic2021-11-05 16:43
Reporterbarrym Assigned To 
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWindowsOS-OS Version10
Summary0018410: MM5 DLNA exporting disabled sub-nodes
DescriptionMM4 DLNA media sharing seemed more efficient and useful than MM5
If I shared a MM4 Collection to my TV, the TV only shows indices for sub-nodes that I had enabled in my MM5 Collection.
In MM5 the TV UI shows ALL sub-nodes ... ie ignores whether or not I have enabled sub-nodes in MM5.

This makes the UI inside the TV messy, but won't it also over tax the limited resources inside a TV?
I tried a large collection, and it broke the TV mechanism ... ie. unable to browse or queue Media inside the TV.
nb. I haven't tried to see whether there is a significant difference to the size of the library that can effectively be served to the TV, but am assuming that there is a difference.

MM4 also allowed me to disable row columns at the Collection level. I presume this change further bloats the data sent to the TV. .. Does it?

Why was this done?

Steps To Reproduce1) Create a MM% collection, and enable minimal number of sub-nodes
2) Share collection via DLNA
3) Browse to MM server in the TV
4) ==> All sub-nodes are available via the TV UI
5) If the collection is large, the TV cannot browse the MM Server
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=488567#p488567
TagsNo tags attached.
Fixed in build

Relationships

duplicate of 0018137 closedLudek Media Servers doesn't pass sub-node selection for Collection 

Activities

rusty

2021-10-12 14:36

administrator   ~0065123

This is currently planned for 5.0.3 and tracked at 0018137.

barrym

2021-10-13 08:46

reporter   ~0065147

OK, but a heads up re deferral to 5.0.3
I tested MM5 in comparison to MM4:
MM4: shared a Collection with 46+k tracks, configured collection to have minimal sub-nodes and columns
==> fully function in the TV ... can browse, can play music, and can see artwork in TV
MM5: same Collection with same configuration (except columns, as n/a in MM5)
==> is broken in TV ... no browsing, no playing,, nothing except error message ("Too much content on this device to list it all")

rusty

2021-11-05 16:37

administrator   ~0065755

Thanks for the heads up. We're aware, but the associated effort/risk mean that it's unlikely we can fit this into 5.0.2.

Ludek

2021-11-05 16:43

developer   ~0065758

Moving to 0018137