View Issue Details

IDProjectCategoryView StatusLast Update
0018288MediaMonkey 5FileMonitor / Find Missingpublic2022-11-29 20:09
Reporterpeke Assigned To 
PriorityimmediateSeveritycrashReproducibilityalways
Status resolvedResolutionreopened 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018288: Deadlock: MM5 locks on startup and crashes on closing (regression 2501)
DescriptionMM5 locks on startup during File monitoring with deadlock and if I terminate File monitoring it crashes on close with log ID 62D60000 regarding UPnP

I even tried to rename folder so that it is missing and that MM5 skips monitoring, even it is still accessible by Explorer, and MM access it without issues.

Full debug logs sent offline.
TagsNo tags attached.
Fixed in build2502

Relationships

related to 0019578 feedbackrusty Improve error handling when DB cannot be accessed 
related to 0018281 closedLudek Crash on Start when WEB node was focused on MM5 restart (regression 2501) 
related to 0019052 closedLudek MM5 2620 Crashed on number of ocasions 

Activities

Ludek

2021-09-13 10:08

developer   ~0064575

Peke, please provide more details + debug/freeze logs.

peke

2021-09-13 10:21

developer   ~0064576

Updated Description, steps and sent logs offline.

peke

2021-09-13 10:24

developer   ~0064577

Ludek

2021-09-13 14:56

developer   ~0064584

This deadlock is actually the same regression as in 0018281 (introduced while fixing 0017895)

Ludek

2021-09-13 18:42

developer   ~0064589

Fixed in 2502

peke

2021-09-13 23:31

developer   ~0064600

Verified 2502

peke

2022-11-29 00:29

developer   ~0070453

Reopen, I got this error while testing MM service installation and service permissions.

peke

2022-11-29 00:30

developer   ~0070454

Unfortunately no log file is created as service was started under "Local Service" permission which DBGView do not log.
image.png (6,696 bytes)   
image.png (6,696 bytes)   

Ludek

2022-11-29 20:06

developer   ~0070460

Based on the crash log it was assertion that MM5 wasn't closed within 10 seconds (this can happen only with debug build).
The reason was that MM5.DB couldn't be accessed during that time (most probably because you were testing the MM service at the same time that was accessing the same DB).
It is quite uncommon situation because normally either MM5 runs as service or MM5 is running (not both at once)

The issue for improving the error messaging re inaccessibility of MM5.DB is now tracked as 0019578