View Issue Details

IDProjectCategoryView StatusLast Update
0017862MediaMonkey 5Generalpublic2021-05-22 17:38
Reporterlowlander Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017862: MP3 file fails to scan
DescriptionA user supplied MP3 file fails to scan into MediaMonkey. However D&D of the file onto the Entire Library node does add it and the file also plays fine. Problem seems to be in the metadata reading.
Additional InformationTicket 1542
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=99047
TagsNo tags attached.
Fixed in build2406

Activities

Ludek

2021-05-17 11:42

developer   ~0063241

Last edited: 2021-05-17 11:44

View 3 revisions

There seems to be a problem reading length of the file, both MM4/MM5 shows length 0:00, but MM4 imports the file and both MM4/MM5 can play the file.
Both AIMP and Foobar shows the correct length (5:13)

Assigned to Michal to analyze.

michal

2021-05-17 15:32

developer   ~0063250

The length is not computed, because the MM4/MM5 does not recognize the file format (after ID3 header), it does not find standard MPEG frames, analyzing more.

michal

2021-05-17 16:07

developer   ~0063251

Fixed in build 2406. XIng header contains wrong/not allowed value in "emphasis" flag. As it does not seem to be problem for playback and other SWs just ignore it, we ignore it from now on too.

lowlander

2021-05-21 22:28

developer   ~0063387

Verified on 2406. The file successfully scans in. Scan log shows it with error reading file info.

lowlander

2021-05-22 17:38

developer   ~0063394

On 2407 file scans with Length and no error in log.