View Issue Details

IDProjectCategoryView StatusLast Update
0017734MediaMonkey 5Casting (Google Cast / UPnP)public2021-04-16 21:19
Reporterrusty Assigned To 
PriorityhighSeverityminorReproducibilitysometimes
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017734: Casting over DLNA: currently playing track sometimes isn't highlighted
DescriptionOn occasion, when playing tracks that aren't contained in the Library via the Folders view, the currently playing track isn't highlighted.

To replicate:
0) Set casting to DLNA
1) Navigate to Folders [Browser: recursive]
2) Double-click the first track
3) After at least 5 seconds of playback click NEXT
--> Doing step 3 several times will usually result in a track not being highlighted

Note: the bug doesn't occur if the user clicks NEXT right away.
Additional InformationReported at: https://www.mediamonkey.com/forum/viewtopic.php?p=480169#p480169
TagsNo tags attached.
Fixed in build2336

Activities

rusty

2021-04-09 16:10

administrator   ~0062766

As reported at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98786 , this issue also occurs for tracks within the library:
Music > Albums > AlbumName [independent of view]
Music > Playlists > PlaylistName [independent of view]

Ludek

2021-04-15 11:17

developer   ~0062831

Fixed in 2335

rusty

2021-04-16 17:56

administrator   ~0062849

Tested 2335 and this issue (or a variant of it) occurs whenever the user clicks NEXT while the current track is buffering:
a) MM doesn't actually initiate playback of the next track
b) the currently playing track (which is the wrong track) isn't highlighted

This can be replicated as follows:
0 Go to any node displaying tracks
1 Enable casting to a DLNA renderer
2 Double click on TrackA
--> Playback on the renderer occurs
3 Click NEXT to play TrackB
--> Track B is highlighted and status bar indicates 'Buffering on...'
4 Click NEXT while the status bar indicates 'Buffering on ....'
--> Track C is highlighted
--> Track B starts playing!
--> No track is highlighted!

Ludek

2021-04-16 18:47

developer   ~0062855

I couldn't replicate, but the key to replicate seems to be use 'Bubble UPnP' as DLNA renderer

Ludek

2021-04-16 19:50

developer   ~0062858

Fixed in 2336

rusty

2021-04-16 21:19

administrator   ~0062864

Verified 2336.