View Issue Details

IDProjectCategoryView StatusLast Update
0017716MediaMonkey 5Otherpublic2021-04-21 10:44
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017716: Crash 9E764AA2 on resuming use of the computer after about 10 hours
DescriptionI've been testing running MM for an extended period to try to determine what causes it to stop responding to wifi sync config attempts after 24hrs. In this case, though MM crashed when the PC was resumed after going to sleep:

1 Run MMW5
2 After 12 hours, in MMA > Options > sync settings [Pixel 2 xl]
--> connects successfully
3 After another 8 hours, PC went to sleep
4 On resume,
---> crashlog 9E764AA2
5 in MMA > Options > sync settings [Pixel 2 xl]
--> Connection failed! error.
6 in MMA, attempt to connect via UPnP
--> Server is unavailable
7 run WMP on the PC and check for MMW5 UPnP server
--> Not listed
8 attempt to interact with the MMW5 UI
--> it fails to respond (i.e. tests 5, 6, 7 are probably meaningless). Also, not sure if this is relevant, but the UI was frozen on the Home > Music screen with the 'Close window' tooltip displaying. MM had to be force-closed.

Note: when attempts to configure sync settings via MMA failed in the past, this crash did not occur, nor the UI stop responding.

EDIT: my machine is configured to _not_ go to sleep when it's plugged in. It occasionally does this though, if the machine is getting hot. With this in mind, it's possible that MM crashed prior to going to sleep and this somehow resulted in high CPU utilization, triggering sleep mode. Also, it's possible that the machine was in hibernation rather than sleep mode (although this too is disabled).
TagsNo tags attached.
Fixed in build2334

Relationships

related to 0017654 feedbackpetr Issues with new version of Eurekalog (regression) 

Activities

rusty

2021-04-01 21:18

administrator   ~0062668

On reading up further on this, I believe that the laptop actually initiated a thermal shutdown, which triggered hibernation rather than sleep. I'll try testing 'normally' triggered hibernation to see if that causes the bug as well.

Ludek

2021-04-03 12:17

developer   ~0062678

Last edited: 2021-04-03 12:18

View 2 revisions

Based on the DbgView log (crash-on-resume-from-sleep.7z) there does not seem to be anything bad before entering the sleep.
The sleep seems entered at 55746 seconds in the log -- as MM currently outputs used memory every minute and it was the last time it outputed before the sleep/hibernation.
at 62771 seconds ( 2 hours later ) - it waked up from sleep/hibernation, then it re-calculated some pixel ratios (like enumDisplays -- Petr's code to check) and
at 62899 (2 minutes later) the freeze log 9E764AA2 has been sent.

But in the freeze log we can see only that UI thread was frozen, but because Eureka logs are missing JS callstacks now (added as item 12) in 0017654) then there is no other info why UI thread has frozen.

Assigned to Petr to:
1) fix 12) in 0017654
2) verify that the frozen UI thread isn't just false positive freeze after returning from sleep/hibernation ? i.e. to verify that the time while PC is hibernated is not considered as "frozen time" by the Eureka ?
3) check the code in enumDisplays for a possible problem

petr

2021-04-03 18:26

developer   ~0062681

Last edited: 2021-04-04 11:16

View 2 revisions

1) fixed
2) fixed

petr

2021-04-04 11:17

developer   ~0062682

Fixed

peke

2021-04-07 21:41

developer   ~0062740

Last edited: 2021-04-07 21:41

View 2 revisions

Verified no crashes in 2333

Not closed as MY PC have Deep Sleep function that completely shutdown PC and only way to wake it is using power button or Wake on LAN command.

Note: Tested on 15 interval and 2h interval. @Rusty can you please confirm and close?

rusty

2021-04-08 02:42

administrator   ~0062752

Verified sleep and hibernation in 2333. Closing.

rusty

2021-04-09 04:02

administrator   ~0062763

This error just occurred again in build 23333. MM was running for a long time doing various things. The last steps before the crash were:
- Wi-Fi sync was started, but it stopped partway through (probably the machine went to sleep/hibernation)
- logged into the machine and MediaMonkey displayed the crashlog dialog for 9E764AA2

Note: it's not clear whether the error occurred before the machine went to sleep or after.

rusty

2021-04-11 00:36

administrator   ~0062779

Last edited: 2021-04-11 00:47

View 2 revisions

Note: this just occurred again upon logging into my machine after 24 hours with MM running in the background. Note that:
- The 'Lookup Audio CD metadata' dialog was displayed
- hibernation was disabled (i.e. the PC only went to sleep).

Note: I always have a CD inserted in the CD drive and a USB key inserted in a USB port (because of issues that these scenarios caused in earlier builds). Could this be related (note that the 'Lookup Audio CD metadata' dialog did not appear the last time this bug occurred)?

petr

2021-04-12 09:50

developer   ~0062783

Fixed

peke

2021-04-21 10:44

developer   ~0062898

Verified 2238

Unable to replicate after 10h of sleep time on one PC and 6h on other.