View Issue Details

IDProjectCategoryView StatusLast Update
0017615MediaMonkey 5Now Playingpublic2021-03-09 02:06
Reporterlowlander Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017615: Playing not focused on active file on MediaMonkey start (regression 2316)
DescriptionWhen starting MediaMonkey the Playing is showing the top of the Playing list instead of the active file in the Player on start of MediaMonkey. In MediaMonkey 4 the Now Playing would focus on the active file on start.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98545
TagsNo tags attached.
Fixed in build2320

Relationships

related to 0016885 feedbackmichal Allow users to define fields in Playing 
related to 0017641 newmichal Initiating playback doesn't trigger playing to scroll to the playing track 

Activities

Ludek

2021-03-02 20:41

developer   ~0062193

Last edited: 2021-03-02 20:46

View 4 revisions

I can't replicate.
The playing file position seems restored correctly for me in both 'Playing list' (on the right) and 'Playing node' (on the left).

Tested this way:
1) Played a playlist with 10K of tracks
2) Seeked to file on position 6471 and played, the screen looks like this: https://www.dropbox.com/s/138fht23qrtaqid/screenshot%202021-03-02%2021.44.22.png?dl=0
3) Restarted MM5
=> the screen is correctly restored to the same scroll position in both lists: https://www.dropbox.com/s/138fht23qrtaqid/screenshot%202021-03-02%2021.44.22.png?dl=0

Ludek

2021-03-02 23:10

developer   ~0062202

Last edited: 2021-03-02 23:10

View 2 revisions

Assigned back to me, after retesting the scroll position isn't always restored for the Playing node

Ludek

2021-03-03 21:06

developer   ~0062228

Last edited: 2021-03-03 21:29

View 3 revisions

OK, the reason why I couldn't replicate in 'Playing list' (on the right) was that I haven't updated SVN sources -- as it is a very fresh regression caused by Michal while fixing 0016885

For 'Playing node' it is fixed in 2318

Ludek

2021-03-03 21:28

developer   ~0062229

The Michal's regression is also fixed in 2318

rusty

2021-03-04 02:43

administrator   ~0062238

This is working for Playing [Simple list], but it doesn't work for Playing [List].

Test note: 'working' means that the scroll position is saved so that MM opens at the position in which the Playlist list had closed (and not as originally requested that it always open at the currently playing track).

michal

2021-03-04 18:49

developer   ~0062247

Fixed in build 2319.

rusty

2021-03-05 20:24

administrator   ~0062267

This is fixed for the List view, but now (in build 2319) the problem occurs intermittently for the Simple List view!

e.g.
1 Switch to Simple List
2 Scroll to track 50 (of e.g.1000) in the Playing list and double-click to play it (and move the list a bit)
3 Close MM, and then restart it once process explorer shows that all processes have closed
--> about 1/3 of the time, when MM restarts, it's at track 1 (even if Track 50 is highlighted in yellow as the currently playing track)

michal

2021-03-06 14:25

developer   ~0062274

Fixed in build 2320. It was collision between restoring scroll position and focused item of the list, and focusing and scrolling to currently active file. We cannot do both, so now we prefer restoring exact last state of the lists.

rusty

2021-03-09 02:06

administrator   ~0062298

Verified 2320.