View Issue Details

IDProjectCategoryView StatusLast Update
0017400MediaMonkey 5Main Panelpublic2021-01-21 02:41
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017400: Playing YouTube video causes MM to terminate slowly and to lose UI settings
DescriptionWhen the user plays a video in YouTube and modifies the view setting (changing from Full Window to Preview and narrowing the width of the Preview window), MM takes a long time to close and on restart, the changed settings are lost! Tested in portable mode. Performing similar tests when playing music do not result in this issue.
Steps To Reproduce1 Run MM (tracks by Charlie Puth [Online] displayed)
2 Double-click on Track 1 from the list of YouTube tracks
3 Move the MM window
4 Play next track
5 Switch from Full-Window to Preview mode
6 Play next track
7 Switch the width/height of the Preview window
8 Close MM
--> It takes MM about 3-4 minutes for all processes to close
9 Restart MM
--> All settings changes made in steps 3, 5, 7 are lost

Note: Performing the same tests using music tracks from the library doesn't trigger this problem
Additional InformationI wonder if this might in some way be related to 0017072 since in that bug, the delay in terminating MM also occurring when MM was stuck at 'Waiting for renderer' in the log.
TagsNo tags attached.
Fixed in build2297

Relationships

related to 0017271 closedpetr MM5: Crash on Close if YouTube track was last played 
related to 0017230 closedpetr MediaMonkey takes 25s to close (regression 2286) 

Activities

Ludek

2021-01-18 20:46

developer   ~0061423

Rusty, please install 2296 and replace both MediaMonkey.exe and MediaMonkeyEngine.exe by these: https://www.dropbox.com/sh/q80mzbba4uln0hc/AAAoO6ddtMgdzyOKq7VdGyaMa?dl=0
Check whether the issue still occurs and generate new debug log (in case you can still replicate)

rusty

2021-01-19 06:10

administrator   ~0061438

Tested this in numerous scenarios. This issue seems to be resolved.

Note that in the course of playing many videos, MediaMonkey can open multiple MediaMonkeyEngine instances (I've seen 4 of them), but they all close within about 15s.

Ludek

2021-01-19 14:28

developer   ~0061446

Last edited: 2021-01-19 14:44

View 4 revisions

Re the MediaMonkeyEngine instances: I see the same when playing YouTube video.
There are up to two additional MME.exe instances running.

Debugging it I see that the command line is
MediaMonkeyEngine.exe --type=utility --field-trial-handle=2704,5609970560872385186,4278017662158408910,131072 --disable-features=IsolateOrigins,site-per-process --lang=en-US --service-sandbox-type=audio --no-sandbox --locales-dir-

Petr indicated that it is an utility process run by Chromium and so far we don't know how to prevent Chromium from running it. Based on this https://support.google.com/chrome/thread/12446461?hl=en it looks that Chromium can create up to 5 such an additional utility processes. These two additional utility processes are with params --service-sandbox-type=audio and the other one with --service-sandbox-type=network .. by evidence needed for the YouTube playback.

Ludek

2021-01-19 18:58

developer   ~0061453

BTW: The Skype also utilizes the exaclty same set of processes: https://www.dropbox.com/s/5bm360o95tb8adj/screenshot%202021-01-19%2019.57.13.png?dl=0
(so seems also running under Chromium).

peke

2021-01-21 02:31

developer   ~0061492

Verified 2297

I am unable to replicate UI loss of settings. Test note non debug version closes 2-3s faster anyway.

rusty

2021-01-21 02:41

administrator   ~0061493

Verified 2297.