View Issue Details

IDProjectCategoryView StatusLast Update
0017377MediaMonkey 5Tagging / organizing (properties / auto-tools)public2022-04-13 23:34
Reporterlowlander Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.3Fixed in Version5.0.3 
Summary0017377: Paste doesn't filter Auto-Complete drop-down in multi-value fields
DescriptionWhen you Paste a value in a field that has the auto-complete drop-down it always shows all the values, instead of the filtered values based on what was pasted.

This doesn't seem entirely consistent, mostly reproducible when adding a value to the end of a multi-value field.

Steps To Reproduce1) Open Properties where a file has a single value in Artists (ie. The Roots)
2) Type ; after The Roots and Paste "Madonn"
3) All values shown (it seems to briefly present filtered, then shows all values)
4) Type "a" and the drop-down list is filtered
(Make sure you do this first when opening the Properties of a file, as some operations on the field can stop this from occurring)

It seems that if you Paste "Madonn" on replacing The Roots, the drop-down properly shows the filtered list.
If you add ; in front of the The Roots and then Paste "Madonn" in front of that it also shows the filtered list.

* without double quotes.
TagsNo tags attached.
Fixed in build2614

Activities

Ludek

2021-05-20 18:26

developer   ~0063331

I cannot replicate in 5.0.1.2405

Can you please re-test whether this is still an issue?

lowlander

2021-05-25 20:41

developer   ~0063479

Testing on 2407 it works as expected if you let MM load the auto-complete after typing ; If on the other hand you paste prior to auto-complete loading it won't always show the auto-complete for the pasted value and instead can either show the full auto-complete or nothing.

michal

2022-04-11 08:43

developer   ~0067506

It does not seem to be related to pasting, the key is the "loading" state of the list, I can reproduce it on large DB even with simple typing "M". Filter is not done in case it is initiated before end of loading the values of the dropdown list. I cannot reproduce the problem at all with small DB and small number of values filled to the whole list.

michal

2022-04-11 15:51

developer   ~0067509

Fixed in build 2614.

peke

2022-04-13 23:34

developer   ~0067537

Verified 2614

Tests are done on 20k+ Artists/Albums dropdowns