View Issue Details

IDProjectCategoryView StatusLast Update
0017256MediaMonkey 5Extensions frameworkpublic2021-11-08 15:41
Reporterlowlander Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017256: Addons doesn't show why Addon can't be removed
DescriptionCertain Addons like the Image Search Service don't offer an option to delete, but there is no reason provided to the user as to why this isn't possible.

A Tooltip would be useful for this.
Additional InformationTODOC:
https://www.mediamonkey.com/wiki/WebHelp:Creating_Custom_Scripts/5.0
TagsNo tags attached.
Fixed in build2512

Activities

rusty

2021-05-25 17:05

administrator   ~0063468

Great point. This is part of a larger issue that the addons page doesn't distinguish between included addons and user-installed addons.

A solution to both problems would be:
a) to identify addons as 'Core' if they're included with MM (and allow the user to filter on this)
b) to not display addons that can't be deleted on the addons page (unless there's a reason for including them that I'm overlooking)

Note: it might be useful to have section headers in the addons list to better organize the list by their primary addon type (instead of forcing the user to filter addons). This assumes that there is a primary type and other secondary Types (e.g. Material Design (Skin, Core). e.g.
General
- Art & Details: 'Side by side' layout
- Case checker
...
Skins
- Monkey Groove
- Material Design
...
Core
- Image Search Service
...

Ludek

2021-05-25 18:45

developer   ~0063474

Last edited: 2021-05-25 18:48

View 4 revisions

I think that current 'Metadata' category fits better for the 'MusicBrainz Service' and 'Video Tagging Services'
Actually I think that 'Image Search Service' should be also moved from 'General' to 'Metadata' category.

As for the reason for including them in the Addons page, the idea was that these services/addons might need more frequent updates (than MM5 app as whole) -- so this way user can update individual service without a need to download install whole MM5 build update/beta.

rusty

2021-10-14 20:02

administrator   ~0065212

1) OK. So perhaps any non-deleteable addon should be identified as a 'Core addon'. e.g.
MusicBrains. Core addon for metadata lookup metadata via MusicBrainz.
Video Tagging Services. Core addon for metadata lookup via OMDB, TVDb.
Image Search Service. Core addon for image lookups.
YouTube Service. Core addon for interfacing with YouTube.

2) Are there any other addons that should be non-deletable / identified as core? e.g. I would have thought that deleting the following would make MMW unstable:
- Touch mode
- Lyric sources

3) Is Video Tagging Services description/icon correct? I thought that TVDb support was removed?

Ludek

2021-10-18 10:07

developer   ~0065279

Fixed in 2511

lowlander

2021-10-22 18:56

developer   ~0065454

1) Core Addon may not explain well to user why it can't be deleted.
A) A Tooltip on the Delete icon could be used to explain that Core Addons can't be deleted.

4) Add a category to Show: Removable Addons

5) Wording is inconsistent eg,
MusicBrainz: Core Addon for metadata lookup metadata via MusicBrainz. (also double metadata?)
Image Search: Image Search Service. Core addon for image lookups. (also capitalization)

It seems MusicBrainz approach looks better (YouTube is also wrong then).

rusty

2021-10-22 20:21

administrator   ~0065460

1) I think the current implementation is sufficient. Th alternative would be a tooltip 'Cannot be deleted because it is core functionality' which isn't any better.

4) I think this is overkill.

5) The intent was to use the MusicBrainz approach for all, but I was unclear that I was suggesting renaming some of the addons. I've clarified below (reverted to the original addon names) and corrected the typo in the MusicBrainz description:
Addon name: Addon description
MusicBrains: Core addon for metadata lookup via MusicBrainz.
Video Tagging: Core addon for metadata lookup via OMDB, TVDb.
Image Search: Core addon for image lookups.
YouTube: Core addon for interfacing with YouTube.

Ludek

2021-10-25 08:23

developer   ~0065482

The wording corrections (5) added in build 2512

lowlander

2021-10-28 22:41

developer   ~0065538

Verified on 2512.