View Issue Details

IDProjectCategoryView StatusLast Update
0017121MediaMonkey 5Syncpublic2020-11-28 11:41
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017121: Update Dropbox API to use refresh tokens
DescriptionStarting September 30th, 2021, the Dropbox OAuth flow will no longer return long-lived access tokens. It will instead return short-lived access tokens, and optionally return refresh tokens.
Details at https://www.dropbox.com/lp/developers/reference/oauth-guide?oref=e
TagsNo tags attached.
Fixed in build2276

Activities

Ludek

2020-11-22 17:50

developer   ~0060340

Fixed in 2276

Test notes: All existing DropBox service profiles are automatically signed out and upon signing in the new OAuth flow is used.
Access token is now short lived (4 hours) and then the refresh token is automatically used to get the new access token.

peke

2020-11-28 11:41

developer   ~0060414

Verified 2276

Looks like refresh token works. Tested in the course of 18h in various times and I was not loged out refresh token is used.