View Issue Details

IDProjectCategoryView StatusLast Update
0017057MediaMonkey 5Generalpublic2021-01-08 00:02
Reporterpeke Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0 
Summary0017057: Sony A55 sync: When full sync is done no playlists are created on device
DescriptionWhen full sync is done no playlists are created on device. Playlist by playlist sync or few playlists works.

Logs, Db , Device profile, ELF, Error screenshot saved on FTP.

NOTE: SDcard.txt is list of files on SD card after the sync.
Steps To Reproduce1. Start DBgView
2. Start MMW 1914
3. Started Sync
4. Waited till it ends or crashes
5. Closed MMW
6. Saved LOG file

Device profile in question is Sony A55 SDcard (It is 256GB SDcard) Internal Sync is not used/synced
Additional InformationTicket 36
Related to:
https://www.mediamonkey.com/forum/viewtopic.php?f=12&t=97107
https://www.mediamonkey.com/forum/viewtopic.php?f=12&t=97215

And Bugs: 0016901 and 0016902
TagsNo tags attached.
Fixed in build2292

Relationships

related to 0006467 closedLudek MediaMonkey (current) Error loading Album art properties when there lots of high res images 
related to 0011068 closedLudek MediaMonkey (current) Speed up playlist USB syncing for general MTP devices 
related to 0017298 closedLudek MediaMonkey 5 MTP Freeze dialog can show multiple times 

Activities

Ludek

2020-11-18 08:20

developer   ~0060271

Last edited: 2020-11-18 08:44

View 7 revisions

There was an unhandled exception when resizing too large images while syncing ( 0006467 )

Fixed in 4.1.31.1915 + merged to MM5

peke

2020-11-21 17:50

developer   ~0060303

Last edited: 2020-11-21 17:55

View 2 revisions

Re opened

User is till experiencing issue of premature terminating the sync with latest SVN. It only copied a few MP3 files and then finished syncing. It didn't crash this time. No playlists written either.

New log, MM.DB and SDcard listing is on FTP.

Ludek

2020-12-28 13:55

developer   ~0061103

Last edited: 2020-12-28 15:45

View 3 revisions

In the debug log I see MTP errors when trying to upload the playlists

WMDM: Uploading file H:\MUSIC\VGM.Mood.Action (4+).m3u8
02105505 16699.94726563 [4180] WMDM: GetStorageFromPath: H:\MUSIC\
02105506 16699.95117188 [4180] WMDM: GetStorageFromPath: MUSIC was not found
02105507 16699.95312500 [4180] WMDM: CreateFolder MUSIC, Insert3: 80070015

i.e. It cannot create folder Music because MTP error 80070015

For some playlists it did not thow MTP error, but takes a long time (more than 30 seconds to upload single m3u file):

 WMDM: GetStorageFromPath: VGM.Amiga(4+).m3u8 was not found
01743474 11104.31933594 [4180] WMDM: Executing action: UploadFile
01743475 11104.31933594 [4180] WMDM: Uploading file H:\MUSIC\VGM.Amiga(4+).m3u8
01743476 11104.31933594 [4180] WMDM: GetStorageFromPath: H:\MUSIC\
01743481 11133.63378906 [4180] WMDM: Executing action: GetCapacity
01743482 11137.18750000 [4180] WMDM: Uploaded: H:\MUSIC\VGM.Amiga(4+).m3u8 Insert3: 0
01743483 11137.18750000 [4180] WMDM: Getting capacity
01743484 11137.18750000 [4180] WMDM: Finished execution of action UploadFile ,took: 32 seconds

EDIT:
Also it seems that for the tracks the standard file system is used for copying (not the MTP) : Copying C:\MediaMonkey 5\Portable\Temp\MM_AutoConvertedTracks\F8B2_065-15 - (We're So Sorry) Uncle Albert.flacF1EB -> H:\Music\3821297116.mp3
But for m3u the MTP is used. This explains why tracks are copied fine, but m3u sucks

SOLUTION: The m3u playlists should be copied via standard file system whenever the drive letter is available (not via MTP).
Moving to MM 5.0.1 -- as this has always worked like this in MM4 and is causing issue only for these specific devices.

Ludek

2020-12-30 18:45

developer   ~0061128

Fixed in 2292

New testing d_WMDM.dll sent to Peke for testing with the affected user

peke

2021-01-08 00:02

developer   ~0061205

Verified 2292

Playlists now sync, but user still complain on 0016901