View Issue Details

IDProjectCategoryView StatusLast Update
0016932MediaMonkey 5DB / Backuppublic2020-09-25 21:45
Reporterpeke Assigned To 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Target Version5.0Fixed in Version5.0 
Summary0016932: Malformed DB: In case of malformed DB error We should offer user to Rebuild DB
DescriptionAs talked offline and testing on my Supplied DB I can confirm that rebuild DB fixes the malformation error (11,11) for such affected DBs.

Current behavior is that MM5 constantly shows Malformed DB error (sometimes multiple ones on top of each other.

As we have never been able to replicate malform (except buy physically damage DB in HEX editor, I would suggest to add option that after multiple repeated errors Mm5 suggest Rebuild DB and if user select auto close error dialogs and perform rebuild which should fix it.
TagsNo tags attached.
Fixed in build2268

Activities

peke

2020-09-19 00:21

developer   ~0059620

Please triage it for 5.0 as Localization strings are not yet concluded.

Ludek

2020-09-21 10:25

developer   ~0059627

In the source code I see that the mechanism for auto-fix already exists and uses existing string:
"'The database seems to be corrupted. Attempt to fix it ?'"

It just did not popped up in your case for some reason, to be found why...

Ludek

2020-09-21 20:49

developer   ~0059633

Fixed in 2268

peke

2020-09-25 21:45

developer   ~0059698

Verified 2268

Verified Rebuild is offered and successful.