View Issue Details

IDProjectCategoryView StatusLast Update
0016873MediaMonkey 5Main Panel: Toolbars & Menuspublic2020-10-25 13:14
Reporterpeke Assigned To 
PriorityhighSeveritytweakReproducibilityalways
Status closedResolutionno change required 
Target Version5.1 
Summary0016873: Editing Last track in artist page do not refresh view
DescriptionEditing Last track in artist page do not refresh view to new artist.
Steps To Reproduce1. Edit some artist by adding suffix to make it incorrect
2. Go To artist node
3. Edit tracks for that artist so that no tracks left on edit
4. View is not refreshed.
TagsNo tags attached.
Fixed in build

Activities

Ludek

2020-08-10 10:25

developer   ~0059308

Last edited: 2020-08-10 10:26

View 2 revisions

Looks like a very minor issue to me.
i.e. the artist becomes empty by renaming the artist of the last track (as is shown on the video) and until user changes the view it is showing the empty artist.

MM could potentially auto-switch to a different view once it detects an empty view (e.g. by emptying artist of the last track), but I can imagine situations where it would have rather undesired effects.
e.g. when renaming the artist of the last track in 'Playing list' then it is rather unexpected for the middle view to be auto-switched.

Whatever approach we are going to take it should be implemented consistently for all attributes (album, artist, genre).
Lowering priority and moving target out of 5.0

michal

2020-08-10 12:41

developer   ~0059309

Resolving, the view IS refreshed, the track is correctly removed from it. It is view displaying original artist, after edit not containing the track.

peke

2020-08-23 17:55

developer   ~0059450

Last edited: 2020-08-23 18:10

View 3 revisions

Shouldn't MM refocus to New Artist (eg. one that triggered no tracks for current view)? That way User can continue managing artist tracks (eg. delete duplicates, correct metadata further, ...).

With Current behavior user need to multiple click in order to continue editing/managing.

Re Ludek: This is for artist/album views where it is prefered to focus to new value.

michal

2020-08-24 07:11

developer   ~0059456

But the view does not know what is "New Artist", view only could display tracklist for the chosen artist (in case this subview is enabled), and this tracklist is automatically updated after any change. Sometimes this change causes removing the track from the list, it could be because it already does not satisfy the filter condition for this list, or it could be caused by deleting the track. The tracklist control is independent on the view, where it is placed.

peke

2020-08-24 15:30

developer   ~0059465

Ok, I'll leave it open and assigned to me for review in case of something can be done for MM 5.1 otherwise I'll close it then.

You are right and now I wonder what other views can be influenced by this behavior as like you said tracklist control is independent on the view.

rusty

2020-10-13 21:34

administrator   ~0059849

Tagging as NCR since I can't think of any preferable behavior. The only other possibility would be to automatically shut down the view, and I don't think that's preferable.

peke

2020-10-25 13:14

developer   ~0059975

Ok, I agree. Closing for now.

It can be reopened if needed.