View Issue Details

IDProjectCategoryView StatusLast Update
0016623MediaMonkey 5Tracklistpublic2020-10-08 20:32
Reporterrusty Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016623: Touch mode: multi-selection sometimes fails
DescriptionIf the user is in a List view in touch mode, and press-holds a track in order to enter multi-selection mode, they can then tap additional tracks to select them (this is useful because the checkboxes currently appear to the right of all columns, and are often offscreen). The issue is that multi selection by tapping additional tracks usually works, except that sometimes it doesn't (causing all tracks to be deselected)!

e.g.
1 In Music > All Tracks [List], tap-hold track 1
2 tap track 2, 3, 4.... to select them
--> at some point, multi-selection fails and all tracks become deselected!
TagsNo tags attached.
Fixed in build2262

Activities

petr

2020-05-19 22:21

developer   ~0058127

Fixed

rusty

2020-05-26 18:06

administrator   ~0058282

Last edited: 2020-05-26 18:31

View 2 revisions

Tested 2251. It seems that the issue is most likely to occur when:
1) the user taps a track right at the edge of the field. e.g.
1 In Music > All Tracks [List], tap-hold track 1
2 tap track 3, 4.... at the upper or lower edge of the track and at the right edge of the column (e.g. the right edge of the 'Title' column
--> almost always, multi-selection is lost and all tracks become deselected!

2) the user switches modes. e.g.
1 In desktop mode, select 3 tracks
2 Switch to touch mode
3 Tap to select another track
--> selection is lost

note: I don't think that the second usecase is terribly important to fix. I'm just pointing it out in case it reveals other paths that might trigger this bug.

petr

2020-07-21 14:30

developer   ~0059045

Fixed

rusty

2020-10-08 20:32

administrator   ~0059777

Verified 2269