View Issue Details

IDProjectCategoryView StatusLast Update
0016600MediaMonkey 5Main Panelpublic2020-09-23 05:30
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016600: Summary format for Art view ignored
DescriptionAs reported here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96525

Option > Player > Playback Rules > Art view
summary format is not used

We should either hide this config in MM5 or apply accordingly in grid views?

Note that also the wording is obsolete as there are no "Art" and "Art Browser" views.
TagsNo tags attached.
Fixed in build2266

Activities

Ludek

2020-05-12 15:51

developer   ~0057968

I guess we might want just hide this config for 5.0 and resolve for 5.1 ?

rusty

2020-05-19 16:32

administrator   ~0058115

Yes for 5.0, this should be hidden.

In truth, I'm not even sure that we'll ever re-enable this functionality in the current format, since there now exist multiple Image types. e.g.
Music > Genre [Grid]
Music > Artist [Grid]
Music > Album [Grid]
Classical > Genre [Grid]
Classical > Artist [Grid]
Classical > Composer [Grid]
Classical > Album [Grid]
Podcast > ....
Podcast > ....
etc...

In other words, there may be a need for users to customize the metadata/links that appear below images based on Type & Node, but it'll likely be in a different location.

Ludek

2020-05-19 20:37

developer   ~0058121

Removed in 2251

rusty

2020-05-26 18:10

administrator   ~0058283

Verified 2251.

rusty

2020-08-31 18:26

administrator   ~0059548

As reported at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97269, the current layout is a bit confusing. Previously it was:

Summary format for individual files:
Player: _mask_
Sample: <example of what this would look like>
(tooltip: Determines how the Summary field displays for different content Types).

Art View: _mask line 1_
. . . . . . .: _mask line 2_
Sample: <example of what this would look like>

This made it clear that the 'summary' was referring to the manner in which individual tracks were displayed in different locations (e.g. in the Player or in Art views).

In contrast, and as pointed out by Barry the current strings don't make it clear at all what the 'Summary' is referring to:
Summary format for individual files:
_mask_ [>>]
(tooltip: Determines how the Summary field displays for different content Types).

Suggested changes:
Display format for 'Track summary' (in Player, Playing):
Format: _mask_ [>>]
Sample: <sample based on the mask>
(tooltip: Choose how the 'Track summary' field displays for each content Type).

As to the potential confusion between 'Track summary' and 'Summary', we could change 'Summary' to 'Album (detail)', but I'd suggest leaving 'Summary' as is for now since it's more generic (and therefore applies better to other content types such as 'TV').

Ludek

2020-09-01 09:43

developer   ~0059552

Fixed in 2266 this way:

Display format for 'Track summary' (in Player, Playing):
_mask_ [>>]
(tooltip: Choose how the 'Track summary' field displays for each content Type).

peke

2020-09-02 01:25

developer   ~0059557

Reminder sent to: rusty

Verified 2266

I would not add ny other change.

@Rusty Please Close after review.

rusty

2020-09-23 05:30

administrator   ~0059647

Verified 2267.