View Issue Details

IDProjectCategoryView StatusLast Update
0016481MediaMonkey 5Properties/Auto-Toolspublic2020-04-08 18:32
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016481: Album art save: Saving Album art for a single track replaces all Album arts in a multi-artist album by default
DescriptionOn Albums that have multiple Album arts and each track have its own album art when user saves Artwork on a single track in album then if [x] Apply to all tracks in Album/Series is enabled (Enabled by Default) it deletes all the Album Arts for each individual tracks.
Steps To Reproduce1. Scan sample album in clean MM5 install
2. Browse to album
3. Edit Artwork track "Walking On Sunshine" delete first Album art (make sure to enable for Apply to all tracks in Album/Series)
4. Press OK
5. Individual Album arts are removed for all other tracks in album and left only Artwork from that track

Desired behavior is delete only if that Album art is present in all other tracks and if not Add Album art from track edited or If "Apply to all tracks in Album/Series" it should add all other Album arts taken from other tracks in album like if you selected all tracks in album and editet Artwork.
TagsNo tags attached.
Fixed in build2239

Relationships

related to 0015456 closedmichal Properties: Artwork. Support for cached images and other tweaks 

Activities

michal

2020-04-02 07:08

developer   ~0057455

It is expected behavior. By checking "Apply to all tracks" you in fact say "all tracks should have these artworks". So the current result is IMHO perfectly ok and corresponds to this clear and easy logic. It is the same like editing any other field and saving it to the whole album.

michal

2020-04-02 07:17

developer   ~0057456

I even cannot imagine how to implement your logic, it would be really confusing, e.g. only decision, whether the image in one track is really the same as in another track, is not easy (it could have slightly different data, but visually look (nearly) the same, etc.). And how would you achieve current result - synchronize the same artworks to all tracks? I think current solution is much better and clear.

rusty

2020-04-02 20:02

administrator   ~0057465

Last edited: 2020-04-03 03:58

View 3 revisions

I agree with Michal-the current behavior is expected. i.e. 'Apply to all files in the album/series' should apply the displayed artwork to all files on the Album/Series.

There is a usability issue, though, as the current default setting is not ideal for multiple-artist albums (since they may have unique artwork per track). i.e. if the user attempts to tag a track for which Artist |= Album Artist, then MM should have 'Apply to all files in the Album/Series' disabled by default.

[EDIT] the problem is actually even worse than originally described. Aside from a bad default in this case, the option gets re-enabled by itself causing all tracks on the album to lose their artwork even if the user disables it:
1 Select a track from a multi-artist album
2 In Properties artwork, disable 'apply to all files in the album/series'
3 Select the art and right-click Remove
--> 'Apply to all files in the album/series' gets re-enabled!!
4 Click OK
--> Artwork is deleted from all of the tracks in the album.

michal

2020-04-05 16:13

developer   ~0057491

'Apply to all files in the Album/Series' checking fixed in build 2239.

rusty

2020-04-08 18:32

administrator   ~0057557

Verified 2239.