View Issue Details

IDProjectCategoryView StatusLast Update
0016472MediaMonkey 5Playlist / Searchpublic2020-04-08 20:24
Reporterpeke Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0 
Summary0016472: Play Now for a node can trigger Playback of tracks different than those that are displayed
DescriptionTweaking issue, for specific case of playing Auto Playlists that have Refresh all

[EDIT by Rusty:
This issue is that when the user right-clicks on a node and clicks 'Play Now' it will not necessarily play the list of tracks that appear in that node. This situation would most often arise for randomized Auto-playlists as originally reported (though it can occur even without 'refresh all'), but can also occur e.g. if the user changes the sort order for Music > Genres > Acoustic Rock and then right-clicks 'Play Now' on the Acoustic Rock node --> MM will play what earlier appeared in the View rather than the resorted version that currently appears].
Steps To Reproduce1. Create Auto Playlists Random 10 TRacks Refresh all
2. Focus playlist
3. Press play icon -> Shown tracks are played
4. Right click on Playlist (while still focused) -> Play Now -> Different 10 tracks played
5. Press play icon -> Shown tracks are played

NOTE: If Playlist is not focused then step 4. acts normally and tweaking this can evade re query due the fact query is already displayed.
TagsNo tags attached.
Fixed in build2239

Activities

rusty

2020-04-02 21:21

administrator   ~0057469

Note that the issue might be more generic than originally described. i.e. assuming that users expect playback to match what's displayed in a node (as if they'd double-clicked the first track in the list), there's another case in which playback order doesn't match display order: if the user sorts Music > Genres > Acoustic Rock [Browser] by Title and then presses the 'Play' button at the top of the screen
--> MM plays the tracks based on the original sort order rather than the displayed sort order.

That said, the issue(s) may be too complex to fix at this stage of MM 5.0 development.

Ludek

2020-04-02 21:51

developer   ~0057470

Last edited: 2020-04-02 21:59

View 6 revisions

Fixed in 2239 for the nodes in 'List' and 'List (by Album)' views.
It also works for most of 'Browser' views where it is clear what is the main view tracklist (e.g. folder/playlist/album).

For the genre's 'Browser' view it takes all genre tracks.

I guess this is sufficient fix for 5.0 and resolves the original issue with the random auto-playlist and also the issues raised by Rusty (when list is re-sorted in the List / List (by Album) view)

rusty

2020-04-07 22:14

administrator   ~0057534

Tested 2239 and this is working well for List and List (by Album) views.

But I don't quite understand what is implemented in some browser views that contain a list, though. e.g.
1 Go to Music > Genres > Acoustic Rock [Browser]
2 Press Play button at the top of the view
--> MM plays tracks based on their order in the list
3 Right click on Music > Genres > Acoustic Rock in the Tree and click 'Play Now'
--> MM plays tracks based on some other non-obvious order!
4 Sort the tracks in the list by a different column
5 Right click on Music > Genres > Acoustic Rock in the Tree and click 'Play Now'
--> MM plays tracks based on some other non-obvious order!

I would have expected that the 'Play' button would yield the same results and 'Play all' for the node.

Anyhow, the issue is fixed for most cases--if this particular case is high risk then we can push to 5.0.1.

Ludek

2020-04-08 20:24

developer   ~0057560

I think that Genre [Browser] view is quite specific (having Artists, Albums, Top Tracks) and one would hardly expect that playing whole genre node would go according to the "Top Tracks" section.