View Issue Details

IDProjectCategoryView StatusLast Update
0016452MediaMonkey 5Main Panel: Toolbars & Menuspublic2020-10-25 13:35
Reporterpeke Assigned To 
PriorityurgentSeveritytrivialReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016452: Search Tab do not reflect searched term
DescriptionWhile searching contextual Search Tab do not reflect searched term.

In my example I searched "ueen" and Tab title shows "u" only while all other shows correct term "ueen"
TagsNo tags attached.
Fixed in build2248

Relationships

related to 0016589 closedLudek Crash A04C0CC1 with Multiple Search Tabs and CD 
related to 0016508 closedLudek Crash when closing tab with global search 

Activities

peke

2020-03-24 19:43

developer  

bug16452.jpg (116,241 bytes)   
bug16452.jpg (116,241 bytes)   

Ludek

2020-03-24 20:23

developer   ~0057328

Last edited: 2020-03-24 21:33

View 3 revisions

BTW: Seeing that the tab header is not rendered/positioned correctly on the "Monkey Groove" and "Black Monkey" skins,
this is a regression after recent Chromium update

=> Fixed in 2235 (together with the original issue)

rusty

2020-03-26 23:33

administrator   ~0057366

Verified 2235.

rusty

2020-04-17 22:07

administrator   ~0057633

There still seem to be problems when multiple Global Searches are performed:
1) Whenever the user clicks a tab containing a previous Global search, the tab and its contents change to the most recent global search!!
2) After changing a global search term that has experienced bug 1), the tab fails to update with the new search term

e.g.
1 Initiate Global search: Term1
2 Open tab 2
3 Initiate Global Search: Term2
4 Open tab 3
5 Initiate Global Search: Term3
--> At this point 3 tabs show: 'Term1', 'Term2', 'Term3'
6 Click tab 2
--> It changes to 'Term3' and the search results are for 'Term3'!
7 Initiate Global Search: Term4 (in tab 2)
--> Search proceeds as expected but tab continues to display 'Term 3'!

Ludek

2020-04-22 12:12

developer   ~0057682

Fixed in 2243

peke

2020-04-23 18:00

developer   ~0057710

Verified 2243

I can't replicate issue noted in 0016452:0057633.

rusty

2020-04-24 17:34

administrator   ~0057739

Tested 2243 and this still isn't working properly if a slightly different usecase is tested:
1 Open Tab 1 and Tab 2
2 In Tab 1 Initiate Global Search for U2
--> Correct search results appear (204 tracks)
3 Click 'Switch to advanced'
4 Add criteria: Genre contains rock and press ENTER (note: Match is set to 'Any')
--> search results expand as expected (4671 tracks)
5 Click Tab 2
6 Click Tab 1
--> Search results for 'U2' appear (rather than being based on the advanced filter) i.e. 204 tracks instead of 4671 tracks!

Ludek

2020-04-27 13:49

developer   ~0057758

Fixed in 2244

peke

2020-04-30 20:00

developer   ~0057802

Verified 2245

Unable to reproduce.

rusty

2020-05-01 15:51

administrator   ~0057813

Last edited: 2020-05-01 15:52

View 2 revisions

Tested 2245 and there's still incorrect behavior when searching in multiple tabs:

1 Open Tabs 1 and 2
2 Global Search in Tab 2 for X
--> Status bar is updated appropriately
3 Global Search in Tab 1 for X2
--> Status bar is updated with results for both Tabs 1 and 2!!

https://www.screencast.com/t/wUZ7QXEAK

Ludek

2020-05-04 12:36

developer   ~0057851

Fixed in 2247

peke

2020-05-08 00:31

developer   ~0057896

Verified 2247

Test note Used steps from 0016452:0057813

rusty

2020-05-08 21:38

administrator   ~0057921

Tested build 2247 and it still seems to have buggy behavior similar to 0016452:0057739 in which the Advanced Search's Match all/any settings get mixed up between tabs:
1 Open MM with 2 music tabs open
2 In tab 2 initiate global search for 'bea'
3 In tab 1 initiate global seach for 'u2'
4 In tab 1 switch to advanced search
--> It shows that it'll search for Match 'All'
5 Add criteria for Genre contains Rock
--> Search results are for U2 OR 'Genre contains Rock' (i.e. the results are expanded instead of constrained)!

As you'll see in my comments in the video, I'm guessing that this may be related to a combination of:
a) issue 1: advanced searches on different tabs have different initial settings (if subsequently initiating an advanced search on tab 2, it is set to Match 'Any')
b) the initial issue from 0016452:0057739 in which Match all/any settings from one tab are applied to another

See: https://www.screencast.com/t/gUymzIH9lk

Ludek

2020-05-10 17:45

developer   ~0057931

Last edited: 2020-05-10 17:46

View 2 revisions

Fixed in 2248 together with the issue mentioned by Barry here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96499

peke

2020-08-24 01:59

developer   ~0059451

Reminder sent to: rusty

Verified 2264

I tested your Rusty description 0016452:0057921 , Berry issue from Topic (Forum updated also) .

I am unable to replicate according to your video. Please confirm.

peke

2020-10-25 13:35

developer   ~0059983

Verified 2271

Closing, retested behaviors, Berry didn't report new issues.