View Issue Details

IDProjectCategoryView StatusLast Update
0016430MediaMonkey 5Generalpublic2020-04-08 18:40
Reporterpetr 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version 
Target VersionFixed in Version5.0 
Summary0016430: Custom Views: Use In issue
DescriptionUse In 'Everywhere' selection doesn't persist.
Steps To Reproduce- define a custom view based upon the standard List view
- constrain the view to some custom collections, deselecting "Everywhere"
- the property "Configure View" dbox may, or may not, be updated, as you expected ... see related issue here re confusion when exiting MM5 config wizard dboxes
- try to exit the above dbox the "right way" so that the "Configure View" property dbox is as you want it
- Press OK
- re-open the config for the custom view ==> deselection of "Everywhere" has been ignored

and issue does only affect the Everywhere setting ... once you have selected a collection, it seems impossible to deselect it
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96067
TagsNo tags attached.
Fixed in build2239

Relationships

related to 0016391 closedpetr List views are not configured/saved per-node 

Activities

petr

2020-03-10 16:24

developer   ~0057137

Fixed

rusty

2020-03-19 17:35

administrator   ~0057232

Last edited: 2020-03-26 17:08

View 4 revisions

In 2232, 'View In:' has been removed completely (i.e. it's not just the Use in: Everywhere option that was removed). So now MM5 again has multiple identically named Views that make it unclear what they're applied to.

From what I see, now any View can be applied to any Collection. E.g. View: CustomClassicalListView can be applied to Music. I suppose we could leave it like this, however, it's somewhat confusing because e.g.
View:List in Classical |= View:List in Music
BUT View: CustomClassicalListView in Classical = View: CustomClassicalListView in Music

That was the reason for adding 'Use in' in the first place--to distinguish between identically named views.

If we don't want to make this a configurable field, another option is to just indicate the Collectio/Root Node associated with the View in the dialog header. e.g.

Configure View: Playlist
-----------------------------------
Name:
View Type:

or

Configure View: Music
-----------------------------------
Name:
View Type:

[Edit] Other cases will be handled similarly. e.g. Configure View: Music > All tracks, or Configure View: Music > Artists, etc.
Note that it should display the part of the path up to which the View is applied to all children. e.g.
- for Music > Location/C:/Music/Live , display Music > Location... (since I presume that all children of that have the same view)
- for Music > All Tracks , display Music > All tracks (no '...' since there are no children)

petr

2020-03-26 17:04

developer   ~0057360

Fixed

rusty

2020-03-29 03:34

administrator   ~0057403

Tested 2237, and this doesn't seem to be implemented at more than the collection level. e.g.

Music > Composer [list] is configured to display the Composer field
Music > Artists [List] doesn't display composer
i.e. they are independent 'List' views (as expected)

BUT
'Manage Views' for Music > Composer [List]
and
'Manage Views' for Music > Artists [List]
both show:
Configure View: Music!

petr

2020-03-29 10:39

developer   ~0057405

Fixed

rusty

2020-04-02 03:01

administrator   ~0057453

This is mostly fixed in 2238, although there are still a few misleading titles. e.g.

1) Music & Music > All Tracks still both display as 'Music' even though they're independent views. Music > All Tracks should be shown.

2) There are a few other similar items:
Music > Genres and Music > Genres > GenreName both display as Music > Genres.
Music > Artists and Music > Artists > ArtistName both display as Music > Artists.
Music > Composers and Music > Composers > ComposerName display as Music > Composers.
etc.
For all such cases, I can't really think of a good solution. Any ideas? If not, I suppose we'll just leave it as is for now.

petr

2020-04-02 09:35

developer   ~0057457

Last edited: 2020-04-02 11:55

View 2 revisions

1) fixed
2) this info is IMHO sufficient

peke

2020-04-08 00:48

developer   ~0057540

Verified 1 in 2239

re 2: I agree that it is enough. Close after confirmation.

rusty

2020-04-08 18:40

administrator   ~0057558

Closing.