View Issue Details

IDProjectCategoryView StatusLast Update
0016402MediaMonkey (current)Synchronizationpublic2020-02-26 16:42
Reporterpeke 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.1.27Fixed in Version5.0.0 
Summary0016402: Sync: Interrupted sync can crash MMW in some cases
DescriptionInterrupted sync can crash MMW in some cases.
Steps To Reproduce1. Set device profile according to attached pic
2. connect device
3. select device in tree
4. Forcefully disconnect device
5. MMW crash

Crash Log file sent offline.
TagsNo tags attached.
Fixed in build

Activities

peke

2020-02-26 03:17

developer  

bug16402.jpg (50,688 bytes)
bug16402.jpg (50,688 bytes)

Ludek

2020-02-26 10:45

developer   ~0056893

Last edited: 2020-02-26 10:46

View 2 revisions

Based on the log you were performing Drag and drop of nodes in Media Tree while disconnecting the device (and the device node was about to be removed).
From the log I don't see why this crash happened - looks like a bug deeper in the VirtualTrees component.

Tagging as resolved in 5.0.0

Let's re-open and move to MM5 (in case you can replicate similar crash in MM5)

peke

2020-02-26 16:42

developer   ~0056897

There was no drag and drop, I just clicked on device in tree and was waiting to settings be shown in track view. It is possible that it was just test moment where I have disconnected device while track view was not shown correctly and tree was stating "..... (Scanning)".

I also agree on resolution. Closing as I can't replicate in MM5