View Issue Details

IDProjectCategoryView StatusLast Update
0016255MediaMonkey 5Generalpublic2020-02-19 17:48
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016255: Radio functionality missing/broken
DescriptionListening to radio streams is problematic in MM5:
1) No node with radio station directory.
i) The following includes an API to list the stations directly in MM
http://www.radio-browser.info
ii) The following sites can be browsed directly and provide direct links to streams
https://www.internet-radio.com/
https://www.radioforest.net/
https://www.rcast.net/dir
https://directory.shoutcast.com/

2) No obvious way to add radio station shortcuts (it is possible, to add a stream as a track, but it's not at all obvious how to do so)
3) Adding a radio station via a stream on the Web node doesn't work because clicking on the stream opens it up in a new external browser window. e.g. add https://radioparadise.com/listen/stream-links as a web node and click one of the links (right-clicking to Open in MediaMonkey doesn't work either since it's disabled on web nodes)
4) If a track is playing and the user rates the track --> An entry for the radio station is added to the Library (but not for the track)!
TagsNo tags attached.
Fixed in build2228

Relationships

related to 0016353 closedpetr Playlist pinning doesn't work 

Activities

jiri

2020-01-16 09:02

administrator   ~0055902

Last edited: 2020-01-16 09:03

View 2 revisions

1i) I like this, it could be useful to have such a service integrated in MM. As for its location, it could have its own node, but maybe better, it could be a part of Devices&Services? I suppose that it won't be accessed too often, but rather would be used occasionally to find new stations to be stored somewhere (see 2.)

2) I wonder whether we couldn't use Pin functionality for this? This way, Pinned Radio stations would be directly accessible from the Home screen.
3) Probably doesn't need to be fixed, if we implement other items.
4) Such a functionality would require knowledge of the playing track, which isn't the case of all radio stations. Something to consider for the future, but I don't see any reasonable solution now.

As for timeframe, I wouldn't defer MM5 because of this, but we certainly can try to implement at least some basics asap.

rusty

2020-01-16 21:43

administrator   ~0055915

1i) Agreed--an integrated directory would be great--but it's probably not implementable for 5.0.

2) Pinning stations would be useful as a way of displaying certain stations. Though I expect that the Radio node should also have a favorites or recently played section.

As far as what to do for 5.0, perhaps the simplest would be to:
A) Add a non-editable Radio node containing the directories listed in 1ii) OR just add them as Webnodes
B) Fix issue 3) so that users can click and play streams from the directories above
C) Add a 'favorites' Playlist sub to 'Radio' and populate it with a few stations. And allow the user to Send-to --> Radio > Favorites

jiri

2020-01-17 07:56

administrator   ~0055940

Petr, could you please:
A) Add the suggested directories as new Web nodes
B) Try to fix 3)
C) Since we don't need a Radio node (yet?), we could pre-create a Radios playlists with few very popular radios included? User could the send his/her favorites to the playlist.

petr

2020-01-21 10:01

developer   ~0056078

Added basic support for Radio streams (clicking on stream or playlist reference). Also any radio stream from NP list can be pinned.

petr

2020-01-21 10:01

developer   ~0056079

Assigned to Rusty for a feedback.

rusty

2020-01-21 16:35

administrator   ~0056088

Last edited: 2020-01-21 16:36

View 2 revisions

Tagging as fixed to trigger testing once the next build is created.

rusty

2020-01-23 20:44

administrator   ~0056187

1) The directories seem to work except Radio Forest is a bit annoying because it plays tracks auotomatically upon clicking a station link. So I'd suggest moving it lower down the list.

2) Pinning stations works at a high level. But there are issues:
a) There's no icon to show that it's a radio station / Stream. Is this possible? If not, it might be preferable to create a 'Radio - Favorites' playlist instead, and have that pinned.

b) It's not identified by the name of the radio station (instead the last-played track shows)
 i) The user can't edit the Properties of the pinned item to rename it. It should be possible to edit a pinned item (it should change the actual item).
ii) Even if the user renames the station's properties via the 'Now Playing' entry, it reverts to the Playing track. This shouldn't occur (in MM4 it didn't).

c) There's no way to pin it from the Player and this is typically what the user would try to do. I would suggest:
- Adding Send to and FMFS to the Player context menu
- Adding 'Pinned' as a child of 'Send to'. This should be implemented across MM5 i.e. 'Pin it' should be eliminated from the context menu.

petr

2020-02-06 10:53

developer   ~0056551

Fixed

rusty

2020-02-07 21:29

administrator   ~0056579

Tested 2227

2a) Verified that right-clicking on a station in Now Playing allows it to be pinned with a 'radio' icon.
2aii) BUT: if the user tries to pin a playlist containing multiple stations --> only the first station in the playlist is pinned!

2b) The station is now identified correctly, but the player no longer displays the tracks being played through the station!
i) Although the Properties dialog now allows the 'Comment' to be edited, there's still no way to edit the Title (which is the only field that displays)!

2c) There's still no way to pin the station from the player. Why not add Send to and FMFS menus to the player?

2cii) There's no way to Unpin pinned items on the Home screen. I would expect that right-clicking an item pinned on the home page should have an 'Unpin' option.

2d) If the user initiates playback of a radio station --> 'Add to library' appears as a context menu. If the user tries to add it and then Search for it, it doesn't appear in the search results. Ideally, it should appear as a Radio station (? within what node ?). Or it shouldn't be possible to add it to the 'Library'.

petr

2020-02-11 11:00

developer   ~0056603

Last edited: 2020-02-11 16:01

View 3 revisions

2aii) currently playlist with more 'radio tracks' are opened in Now Playing as a separate tracks so user can pin track by track OR we can add new command to NP menu
- 'Pin playlist' - this could store all tracks from NP to the new playlist and pin (i prefer this)
or
- 'Pin all tracks' - this could pin automatically all tracks from NP

2d) currently radio station name is stored in Album property so user should be able to search (using our built-in search)

rusty

2020-02-19 17:48

administrator   ~0056727

2aii) This has been fixed by 0016353 -- i.e. no additional changes are needed.
2b)/2c) Verified
2d) OK