View Issue Details

IDProjectCategoryView StatusLast Update
0016235MediaMonkey 5Main Panelpublic2021-09-20 23:52
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0016235: Artwork and Summary are not removable in "List (by Album)" view
DescriptionAs reported here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95677&p=464140#p464139

In the "List (by Album)" view the Artwork and Summary are not removable via "Choose columns" dialog.
Workaround is to right-click column header > Hide column, but this causes that the Artwork/Summary cannot be re-added!!
TagsNo tags attached.
Fixed in build2503

Relationships

related to 0018090 closedmichal Groups is shown on List View when selecting Columns to be displayed (right click) 
related to 0018296 feedbackrusty Track Browser: Artwork and Summary columns should be pinned to top of Choose column list 

Activities

petr

2020-01-06 18:43

developer   ~0055806

fyi Artwork and Summary can be enabled under Group section in right-click header menu.

petr

2020-01-14 12:38

developer   ~0055839

Fixed

peke

2020-01-15 01:27

developer   ~0055846

Verified 2220

Now It can be removed in both chose collums and in context menu.

Ludek

2020-11-26 17:33

developer   ~0060384

Isn't there a regression?

I hidden the Summary column, but I cannot add it back: https://www.dropbox.com/s/iv1f9l48lxjkpj6/screenshot%202020-11-26%2018.32.33.png?dl=0

petr

2020-11-26 18:24

developer   ~0060387

Fixed

peke

2020-11-28 11:56

developer   ~0060423

Verified 2276

I can't replicate @Ludek please confirm.

peke

2020-12-18 02:01

developer   ~0060905

Re verified 2286 for regressions

User also confirmed fix.

Ludek

2021-09-09 08:47

developer   ~0064504

Re-opened as there seems to be a regression:
1) Go to Music > All tracks [ "List (by Album)" view]
2) Hide Summary and Artwork
3) Restart MM5
=> Summary and Artwork are re-added!

This does not happen with others columns.
[Ticket # 2602]

petr

2021-09-09 16:10

developer   ~0064513

Fixed

barrym

2021-09-10 08:43

reporter   ~0064514

Maybe this change creates an issue.
In MM4 the collapsed size of the album group was set in Tools|Options|Library|Appearance.
In MM5 the collapse size is set by stretching|shrinking the Art column.

How will this work if the user has removed the Artwork column?

lowlander

2021-09-10 20:55

developer   ~0064528

Last edited: 2021-09-13 23:07

View 2 revisions

When adding Artwork or Summary to List (by Album) in All Tracks their info is added in the Title Column (first column shown) instead of it's own column.

This persists after MM restart.

Removing the added Artwork column (shown in Title) does have it still removed after MM restart.

petr

2021-09-13 12:04

developer   ~0064581

Fixed

lowlander

2021-09-13 23:10

developer   ~0064598

Verified on 2502, Artwork and Summary are now their own column.

barrym

2021-09-14 08:26

reporter   ~0064607

I Installed 2502 ... portable, clean install, ie. no import from MM4.
List By Album View does not include Artwork or Summary columns. ... Why is that the default?
The result is horrible. The report has many blank rows embedded throughout.

And as I said in my note above, there is no apparent way to alter the album' collapse size (ie number of track rows displayed per album) without the Artwork column.
Additionally, without the artwork column, there is now no click action to select a whole album,

nb. I don't understand the Use case for deleting these columns from Album by View. There should be a grouping column.

barrym

2021-09-14 08:43

reporter   ~0064608

The blank row holes are caused by any album with insufficient tracks to have consumed all the rows that would have been allocated to the album, if the albumart was displayed.
The holes are large, because in the absence of the album art rectangle to assign the minimum height for the album, it looks like a default of 12 tracks has been assumed.
 
see here https://www.dropbox.com/s/k4kbtv6m7fcmz3w/%28w%29holey%20mess.png?dl=0

I would consider pulling 2502 if that is possible.

petr

2021-09-14 12:17

developer   ~0064610

Fixed missing Artwork and Summary columns on clean install.

barrym

2021-09-14 13:20

reporter   ~0064611

What about of all the blank rows, is that issue fixed?
And the other two things that I mentioned are OK? ..
I presume that you are implying that they are OK because the user is effectively responsible for disabling View functionality, by removing the Artwork column.

Maybe, sort of ... but all the all the blank rows seems undesirable to me.
And I still don't understand the Use Case. It seems to me that this change is going to create Support traffic, so there has to be a gain doesn't there?

What is a List By Album View, without a group column, that an appropriately sorted List view didn't already provide?

Ludek

2021-09-14 19:45

developer   ~0064623

The blank holes are in MM4 too (when Summary+Artwork is disabled in Art+Details view).
I see it as very minor issue. In true disabling Artwork+Summary doesn't make much sense from the user perspective. It is better to switch to standard 'List' view.

lowlander

2021-09-20 23:52

developer   ~0064772

Verified on 2503, clean install has Artwork and Summary enabled in List (by Album).