View Issue Details

IDProjectCategoryView StatusLast Update
0016225MediaMonkey 5Main Panel: Toolbars & Menuspublic2020-10-29 15:00
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version5.0Fixed in Version5.0 
Summary0016225: Album art is not Updated in UI
DescriptionEditing and finding Album art for playing track do not update AA+Details on Playing track.
Steps To Reproduce1. Browse using Folders for track that is not in library (I used FLAC files)
2. Play the track
3. Edit Properties Album Art
4. Save Album art in tag
5. AA+Details is not updated

Opening properties of track -> Artwork track shows AA saved in tag.
TagsNo tags attached.
Fixed in build2220

Relationships

related to 0017033 closedLudek Image grids are slow to load (regression) 

Activities

Ludek

2020-01-03 13:44

developer   ~0055790

Last edited: 2020-01-03 14:03

View 4 revisions

I have been debugging this and the problem seems to be that thumbs cache is not updating correctly for non-library tracks/albums.

Namely getting thumb in artWindow.js via uitools.getItemThumb with parameter canReturnAlbumArtwork set to true

Also, it seems to me that track.saveCoverListAsync is missing from propertiesTabs.tabArtwork.saveAsync , is this correct?

Assigned to Michal to look into it (as it is his part of code).

michal

2020-01-10 11:50

developer   ~0055834

Fixed in build 2220.

peke

2020-01-15 01:32

developer   ~0055848

Verified 2220

Looks like working now. Tested on 50+ files