View Issue Details

IDProjectCategoryView StatusLast Update
0016137MediaMonkey 5Now Playingpublic2019-12-17 00:21
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0016137: Playing View: Artist info is not refreshed on track change
DescriptionWikipedia Artist info is not refreshed on track change. Only way to refresh is to Restart MM5.

LOG Uploaded to FTP.
Steps To ReproduceSteps from LOG:
1. MM5 Started with Artist "Amen" in Playing view (Artist Bio) and Info is fetched.
2. Played number of Tracks from Various artists (Note Background Picture Updated normally when available/found)
3. Closed MM5 on track played by Artists Antiqua
4. Started MM5 and Antiqua Artist info is fetched from wiki
5. Played number of tracks from various Artists including "Pet Shop boys" No Artist updates
TagsNo tags attached.
Fixed in build2219

Relationships

related to 0015181 closedmichal Repeated unnecessary lookups in Now Playing immersive mode 

Activities

rusty

2019-11-23 23:45

administrator   ~0055473

fyi: I can't replicate using the steps above.

petr

2019-11-24 08:55

developer   ~0055480

Cannot reproduce

Ludek

2019-11-25 20:21

developer   ~0055497

I also cannot replicate, assigned to Michal as the last code related to this (in artistBio.js) are Michal's changes when fixing 0015181 (SVN revision 32245)

michal

2019-11-28 07:24

developer   ~0055519

I cannot reproduce too. There were some fixes in this several days ago, please retest in the next build.

peke

2019-11-29 02:44

developer   ~0055547

Same behavior in 2217

michal

2019-12-02 14:37

developer   ~0055584

Fixed in build 2219. It was related to changing tracks from albums with "Various" album artist.

peke

2019-12-17 00:21

developer   ~0055705

Verified 2219

It is correctly updated now.