View Issue Details

IDProjectCategoryView StatusLast Update
0016096MediaMonkey (current)DB/FileMonitorpublic2020-01-09 16:22
Reporterpeke 
PriorityurgentSeverityblockReproducibilityunable to reproduce
Status closedResolutionfixed 
Product Version 
Target Version4.1.26Fixed in Version4.1.26 
Summary0016096: DB: DB initialization/Upgrade fail MM can't start
DescriptionIf MM crashes during update/init of MM.DB that left library corrupted on next start MM should check DB integrity and delete/rename MM.DB to MM.DB.Corrupted in order to either create new MM.DB or try to reimport/upgrade backup DB created during init/upgrade process.
Additional InformationSSV-602-19043
TagsNo tags attached.
Fixed in build1896

Activities

Ludek

2019-11-07 14:10

developer   ~0055249

Last edited: 2019-11-07 14:12

View 3 revisions

The problem is that "PRAGMA integrity_check;" on the user's database returns "OK" (ticket SSV-602-19043), but the database has only 97 KB, includes just one row in DBInfo table and Songs table has 10 entries where all values are NULL.

Nevertheless I will add checking of DBInfo table, it must always include 4 rows (consisting of version major, minor, release and database id).
If the check fails then the MM.DB will be renamed to MM.DB.corrupted and fresh MM.DB will be created.

Ludek

2019-11-07 14:18

developer   ~0055250

Added in 4.1.26.1896 and merged to 5.0.0.2212

peke

2019-12-02 09:34

developer   ~0055574

Verified 2218

Close after test in 1896

peke

2020-01-09 16:22

developer   ~0055831

Verified 1896

Closing