View Issue Details

IDProjectCategoryView StatusLast Update
0016041MediaMonkey 5Playlist / Searchpublic2019-10-24 15:08
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016041: Contextual Search: auto-suggest text is misaligned
DescriptionWhen the user starts typing contextual search terms, the suggested search terms are correctly aligned. But as the user types more and more, the number next to 'Artists' adjusts and causes the textbox to be misaligned.

see: https://www.screencast.com/t/RZ3XkaE6

Note: the crash in 0016040 might be related to this.
TagsNo tags attached.
Fixed in build2207

Relationships

related to 0015730 closedmichal Contextual search auto-suggest UI issues 

Activities

rusty

2019-10-18 15:23

administrator   ~0055048

Note: I meant that perhaps the crash described at 0016040 might be somehow have been triggered by this issue. This issue does occur upon fresh startup (and 0016040 necessarily always has to experience this issue because this issue always occurs when doing a contextual search in the Artists node).

Ludek

2019-10-18 15:44

developer   ~0055052

Last edited: 2019-10-18 15:44

View 2 revisions

This issue has been already fixed as item 1) in 0015730 by Michal.

I've not seen this issue since the fix -- and I cannot replicate now.
Assigned to Michal to review his previous fix of 0015730 / 1

Ludek

2019-10-18 15:56

developer   ~0055053

Hmm, just installed 2205 debug portable and I am seeing the issue!

I previously tested on current sources where the issue does not occur, so considering as fixed in 2206.

Ludek

2019-10-18 16:15

developer   ~0055054

Last edited: 2019-10-18 16:17

View 3 revisions

Re-opened:

The reason why I could not replicate previously was that the [Music > Artists > ...] did not show number of artists in the brackets for some reason.
I am not sure why it sometimes does not show it, I mean [Music > Artists (135) > .....]

When the number of artists is displayed then the position of the dropdown varies based on the number width and moves on -- resulting in the issue.

Ludek

2019-10-21 11:55

developer   ~0055066

Fixed in 2207

rusty

2019-10-24 15:08

administrator   ~0055101

Verified 2207.