View Issue Details

IDProjectCategoryView StatusLast Update
0016027MediaMonkey (current)Synchronizationpublic2019-10-09 11:37
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version4.1 
Target Version4.1.26Fixed in Version 
Summary0016027: iPhone: Purchases can no longer be played in MediaMonkey (due to DRM protection)
DescriptionWhile testing iOS13 sync I tried to play a purchased track from MediaMonkey > iPhone > Music > ...
The track has iPhone path like '/CloudAssets/e1d5b8c6-65de-41ba-8266-71aa077c0384.m4a'

I was debugging this and found that MM transfers the file to the temporary directory without an issue, but the M4A file fails to play in any media player.
Probably a missing tag or format info in the M4A file header?
Uploaded as e1d5b8c6-65de-41ba-8266-71aa077c0384.m4a to FTP for analyzing.
TagsNo tags attached.
Fixed in build

Activities

Ludek

2019-10-09 11:20

developer   ~0054987

Last edited: 2019-10-09 11:22

View 2 revisions

In the debug log I saw:
[9236] f_MP4: This file contains DRM!

So the purchase seems to be DRM protected file.

Ludek

2019-10-09 11:28

developer   ~0054988

Last edited: 2019-10-09 11:37

View 4 revisions

QuickTime 7.7.9 (the last -- though 5 years old version) also fails to play the file, it throws following error:
-2002: a bad public movie was found in the movie (e1d5b8c6-65de-41ba-8266-71aa077c0384.m4a)

Thus also our f_aac plugin fails with the same QT error:

[9236] F_AAC: QT install check.
[9236] F_AAC: QT version check.
[9236] F_AAC: EnterMovies().
[9236] F_AAC: EnterMovies(): 0
[9236] F_AAC: DRM protected track.
[9236] F_AAC: NPNTFSS(C:\Temp\mp4\e1d5b8c6-65de-41ba-8266-71aa077c0384.m4a): 0
[9236] F_AAC: OMF(): 0
[9236] F_AAC: NMFF(): -2002


Ludek

2019-10-09 11:36

developer   ~0054989

So resolving as "not fixable"