View Issue Details

IDProjectCategoryView StatusLast Update
0016024MediaMonkey 5Main Panel/Toolbars/Menuspublic2019-10-25 01:51
Reporterpeke 
PriorityhighSeverityfeatureReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target Version5.0Fixed in Version 
Summary0016024: Address Bar: There is no way to focus tree node on clicking on address bar
DescriptionThere is no way to focus tree node on clicking on address bar, which is user unfriendly.

1. Right click on Now playing track -> FMFS -> Folder (Library/My Computer) NOTE: Same works on any FMFS option
2. Tracks are show but Tree node is not moved focused (As Designed)
3. Clicking on ALL or Last Folder in address bar it is expected to Focus that tree node

It is very complicated with numerous scrolls and mouse clicks to go to desired folder/view.

Test Note: Clicking on ">" navigate and show subnodes, but Tree Nodes are unusable or hard to get to as noted above.
TagsNo tags attached.
Fixed in build

Activities

peke

2019-10-08 11:55

developer  

bug16024.jpg (86,326 bytes)
bug16024.jpg (86,326 bytes)

rusty

2019-10-18 13:47

administrator   ~0055045

What you're suggesting would imply that clicks to the breadcrumbs bar should _open_ nodes in the tree. I don't think that would make sense because for many users the tree is just for switching between high-level items (e.g. Music/Podcasts) i.e. if they're not using the tree because they prefer to use the folders in the main view.

peke

2019-10-18 19:56

developer   ~0055056

No, I was referring to clicking on String as ATM it is clickable but no click Action assigned.

For me it is logical that clicking on String Focus tree on that. As After that user can use D&D to move hole folders.

rusty

2019-10-25 01:51

administrator   ~0055116

The problem is that the UI is designed to not assume that the tree exists (because in many cases it isn't used) or that the user uses it in expanded form. e.g. if a user has a tree just showing Home, Playing, Music, Classical, etc. (all root nodes):
- FMFS Artist does _not_ open the tree because the user doesn't want tree nodes open
- Clicking on hyperlinks in the A&D/Preview window doesn't open the tree for the same reason
- Similarly clicking on any portion of the breadcrumb bar does not / should not start opening the tree.

We could add a contextual command to 'Open in tree', but I'm not keen on that either because the UI currently doesn't make assumptions about the tree being open.