View Issue Details

IDProjectCategoryView StatusLast Update
0015942MediaMonkey 5Properties/Auto-Toolspublic2019-10-24 16:39
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015942: Auto-tag: issues with foreign language tracks / incorrect coloring of fields
DescriptionI've recently done some auto-tag testing with a bunch of Hebrew tracks and noticed a few anomalies (I'm not sure whether it's related to the hebrew characters or notbsince I've noticed issues 2 and 4 on occasion in the past with english tracks):

1) Poor recommendations for some tracks with missing almost all metadata
tr1) -- .mp3, a hebrew track, gets a recommendation of a classical music track
tr3) ...Hadvarim.mp3, which previously had metadata gets recommended a more generic recommendation: Title:Track03, Artist:Unknown
 
2) Artist/Album/Album Artist fields appear in white despite new recommendations. They should appear in orange.
tr4) --().mp3 Occurs for Artist/Album/Album Artist fields
tr7) - -(1).mp3 (track 2 in the list) Occurs for Artist/Album/Album Artist fields
tr8) --(1).mp3 (track 5 in the list) Occurs for Album field

3) Changing the Album Artist doesn't work (not even to the initial value)
tr5/tr6) Two tracks by Idan Raichel fail in this manner

4) Artist field appears in white despite a conflicting recommendation. It should appear in orange with an !
tr9) (track 3 in the list)

https://www.screencast.com/t/v4L4xk87Jp3X
test files (without full paths) are in auto-tag_test-files_update13
TagsNo tags attached.
Fixed in build2204

Relationships

related to 0015951 closedpetr Auto-tag: include existing metadata as suggestions for Album Artist 
related to 0015941 closedpetr Auto-tag: recommends album artist from the next track for the current track 
related to 0015961 closedrusty Auto-tag: many tracks shown as having conflicts (regression 2198) 
related to 0015966 closedpetr Auto-tag: Poor recommendations are sometimes made (even when high confidence levels are required) 

Activities

rusty

2019-09-13 15:44

administrator  

auto-tag_strange-behavior-hebrew-tracks.7z (203,340 bytes)

petr

2019-09-15 11:13

developer   ~0054650

Last edited: 2019-09-15 12:12

View 5 revisions

re 1)
track 1: fingerprinting returns just one recommendation ...
track 2: this track have filled just title and album and we didn't found this track in MusicBrainz (using this two values) ... for this reason fingerprinting is used and it returns only recommendation

re 3) we've decided to disable recommendations for Album Artist as we have no way how to get track artists recommendations (MusicBrainz have no support for this)

petr

2019-09-15 12:13

developer   ~0054651

Fixed

peke

2019-09-18 06:14

developer   ~0054681

Last edited: 2019-09-18 06:14

View 2 revisions

Tested in 2198 using Serbian Latin and Cyrillic names and Latin works without problem, but Cyrillic do not return results or return Russian results (I think that it is due the lack of Cyrillic entries as officially both are equally used for writing in Serbia),

Test Notes: Best results and examples are found from Serbian artists "Riblja ?orba" and "?or?e BalaĊĦevi?"

rusty

2019-09-20 14:50

administrator   ~0054742

Last edited: 2019-09-20 14:51

View 2 revisions

Tested 2198:
1) Tracking at 0015966

2) Verified, but this may have introduced regression 0015961 (track 8: Mimcha ad Elai exhibits that problem). Holding off on closing to reverify once 0015961 is resolved.

3) Tracked at 0015951

4) Verified, but holding off on closing until 0015961 is resolved (since they may be related).

5) Peke: Re lack of Cyrillic results: is this a bug? i.e. do the results exist in the MB database and they weren't found? I'm asking because you seem to be saying that there's a bug, but you didn't re-open the issue.

peke

2019-09-20 20:14

developer   ~0054752

5) It looks like normal behavior, non Latin 1/2 characters like Cyrillic searches are returning mixed or no results, so it is documented as tested because it is very possible that we can't fix the search results uless specific case is found of missed results.

rusty

2019-09-25 18:21

administrator   ~0054852

2) This is partially fixed except that track "- - (1).mp3" (with the Title of "(1)" has a newly recommended Album, but it appears in white instead of orange!

4) Verified

6) There seems to be a regression: Date, Year, and Lyrics often appear in orange for tracks in which there's no change! Sample track: 059 - Bad - Wale ft. Tiara Thomas

petr

2019-09-25 19:17

developer   ~0054853

Fixed

rusty

2019-09-26 20:09

administrator   ~0054868

2) Verified

6) I was able to verify this, however, the fix could be improved since in 2202 the year/date flashes orange and then changes to white. It would be cleaner if it just appeared white to begin with.

petr

2019-09-27 11:15

developer   ~0054877

Fixed

rusty

2019-10-04 05:46

administrator   ~0054932

Verified 2203 however, there's a new regression:

7) Album Artist that is unchanged will often appear Orange, but _only_ in the summary image. See image below.

8) Unrelated, but trivial so noting it here: The Album/Album Artist that appear in the summary aren't perfectly left-aligned with the Album: and Album Artist title. You can see it in the image as well.

rusty

2019-10-04 05:46

administrator  

album-artist_orange.jpg (12,262 bytes)
album-artist_orange.jpg (12,262 bytes)

petr

2019-10-04 07:02

developer   ~0054937

Fixed

peke

2019-10-17 23:17

developer   ~0055022

Verified 2205

7) No shows White

8) Aligned

Test Note: On first test in 2204 few days ago I needed to delete persistent.json but using same Persistent.json I used in testing 2204 on 2205 it worked without deletion.

rusty

2019-10-24 16:39

administrator   ~0055104

Verified 2207.