View Issue Details

IDProjectCategoryView StatusLast Update
0015896MediaMonkey 5Otherpublic2020-05-05 21:08
Reporterpeke 
PriorityimmediateSeveritycrashReproducibilitysometimes
Status closedResolutionreopened 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0015896: Crashlogs often not sent
DescriptionThere are several reports that logs are not sent recently due the sending thread gets crashed.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94971
TagsNo tags attached.
Fixed in build2244

Relationships

related to 0016575 assignedpetr Add path to crashlog in Debug MSGs during MM startup 

Activities

petr

2019-09-11 13:09

developer   ~0054590

Made some changes in chromium so hopefully it will be better. Feel free to reopen when my change doesn't make it better.

rusty

2019-10-18 15:40

administrator   ~0055051

in build 2205, almost every time a crashlog is generated when I click the 'Send logs' button
--> Sending bug report... dialog appears
--> Sending message... displays in the dialog
--> But the progress bar fails to advance giving the user the impression that nothing was sent!
(this is why I often save debug logs to the ftp server--because it appears that they weren't sent!)

Peke has indicated that sending the logs works if 'Send logs' is clicked within 5 seconds of the crash, however, that's not my experience. Regardless, this isn't realistic since it doesn't give the user time to copy the log ID.

Ludek

2019-11-21 22:21

developer   ~0055438

FYI: We found with LowLander that when crash log fails to submit then workaround is to delete the MediaMonkeyEngine.el file and the submitting works again (for the new crashes).
For him also using [Help > Debug > Send logs] always failed to send the logs --> until he deleted the old MediaMonkeyEngine.el file from the disc.

Petr adjusted EurekaLog configs to not cumulate the old crash logs in the MediaMonkeyEngine.el file -- which might resolve the issue, let's see in 2215+

Ludek

2020-01-02 17:53

developer   ~0055784

Last edited: 2020-01-02 20:03

View 3 revisions

It still happens in 2219 according to users here:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95421
and here:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95670

petr

2020-01-03 21:39

developer   ~0055793

Last edited: 2020-01-04 11:45

View 2 revisions

Added code to store last error log to {MM dir}\MediaMonkey.elf file when renderer crash.

petr

2020-04-23 14:13

developer   ~0057706

User should be able to send us elf file saved in MM install folder.

peke

2020-04-23 21:15

developer   ~0057726

As talked offline it would be better to save it into "\Roaming MediaMonkey 5\" as it is common MM folder than program files and avoid any possisble access permission issues.

petr

2020-04-23 21:20

developer   ~0057727

done

peke

2020-04-23 21:32

developer   ~0057729

Last edited: 2020-04-23 21:32

View 2 revisions

As talked offline Petr has done another change for 2244 in order to be consistent with both Normal and Portable install result of "ExtractFilePath(MMDBFilename));" is used as ELF file destination save folder.

peke

2020-04-30 03:12

developer   ~0057786

Verified 2244

Looks ok and ELF is in Right place.