View Issue Details

IDProjectCategoryView StatusLast Update
0015885MediaMonkey 5Properties/Auto-Toolspublic2019-12-02 01:19
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015885: Auto-tag: gets stuck on certain files
DescriptionI've experienced a couple of problems recently that prevent auto-tag from working:
1) Select 62 tracks, initiate auto-tag lookup (successfully) and then click 'Auto-tag' --> MM gets stuck updating the database
(I'll send you a debug log)

2) Select the same 62 tracks, initiate auto-tag lookup --> lookup get's stuck at track 52
(I'll send you the files and debug logs)

p.s. I wonder if issue 2) was somehow caused by issue 1 (since the tracks initially were looking up correctly--i.e. issue 2 only started happening consistently after issue 1) occurred.
TagsNo tags attached.
Fixed in build2196

Relationships

related to 0015886 closedpetr Auto-tag: fingerprint lookup initiates metadata search for a different file 
related to 0016155 resolvedpetr Auto-tag: can get stuck in an infinite loop 

Activities

rusty

2019-08-28 19:16

administrator   ~0054435

I've been testing auto-tagging again today and have noticed possibly related issues:
when tagging large numbers of tracks, the status indicator sometimes gets 'stuck' loading artwork on a particular track e.g. track 2 of 75, and although the debug log shows that progress is being made loading various metadata, the status bar continues showing that MM is stuck on that particular track (and continues showing this even after all metadata has apparently finished loading)!

petr

2019-09-10 20:37

developer   ~0054582

Fixed

rusty

2019-09-11 00:44

administrator   ~0054587

Test note: this also includes a fix to the problem that the status bar in the auto-tag dialog counts progress incorrectly when > 100 tracks are being auto-tagged.

rusty

2019-09-13 01:50

administrator   ~0054613

Verified 2196:
- auto-tagging no longer gets stuck
- count is now correct