View Issue Details

IDProjectCategoryView StatusLast Update
0015881MediaMonkey 5Skinspublic2020-09-23 04:40
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0Fixed in Version5.0 
Summary0015881: Changing skin while auto-tag dialog open causes MM to freeze
Description1 Select 50 tracks and run Auto-tag and start editing tracks
2 Switch skins (because some UI elements aren't visible with Monkey Groove)
--> The Auto-tag dialog closes and all work in progress is lost!!
TagsNo tags attached.
Fixed in build2267

Activities

rusty

2020-01-22 22:45

administrator   ~0056134

Re-tested with 2221 and the issue is now worse. Now MM freezes when switching skins in this scenario.

petr

2020-07-03 08:56

developer   ~0058743

Currently changing skin closes all windows except main window and start new browser/context (HTML/JS environment) so it could be tricky to change it now ... i do not see any easy way how to do it for 5.0.

rusty

2020-07-03 22:42

administrator   ~0058760

As a workaround, could you pop up a dialog:
'This will terminate all existing processes.'
[Proceed] [Cancel]

Proceed --> open dialogs are closed and the skin change then occurs
Cancel --> skin change doesn't go ahead

petr

2020-07-04 14:06

developer   ~0058768

Added a info window

peke

2020-07-11 01:01

developer   ~0058878

Verified 2260

Info is shon and behave as designed.

Ludek

2020-09-04 19:31

developer   ~0059561

Last edited: 2020-09-04 19:32

View 2 revisions

Re-opened as the current message is not clear enough, details discussed at https://www.mediamonkey.com/forum/viewtopic.php?p=472375#p472375

Currently the message isn't accurate because:
1) it is not true that all processes are terminated (e.g. playback continues on background while skin is re-loading)
2) After uninstalling an extension and closing the Extension dialog this message is shown too, but the context is not clear

So I guess that wording could be changed to something like:
"MediaMonkey is going to reload (which may result in terminating existing processes)"
[Proceed] [Cancel]

?

rusty

2020-09-16 17:26

administrator   ~0059589

"MediaMonkey will reload (which may terminate existing processes)."
[Proceed] [Cancel]

Ludek

2020-09-17 10:04

developer   ~0059592

Last edited: 2020-09-17 10:04

View 2 revisions

The new wording and confirmation applied in 2267

rusty

2020-09-23 04:40

administrator   ~0059646

Verified 2267.