View Issue Details

IDProjectCategoryView StatusLast Update
0015880MediaMonkey 5Skinspublic2019-08-29 01:58
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015880: Player: some items rendered/positioned incorrectly
Description1) In all skins, the Player volume control's hash marks appear below the control!

2) In the material design skins, the visualizer isn't centered vertically (it's not aligned with any other player UI elements).
TagsNo tags attached.
Fixed in build2192

Activities

petr

2019-08-14 09:35

developer   ~0054339

re 1) they was always below the control. Do you want to remove them ?

michal

2019-08-14 16:03

developer   ~0054347

2) fixed in build 2192.

1) I also do not understand, what should be wrong with marks, they are below by design. They could be hidden, above, below, above+below or in the center. If you would like to change it, let me know how...

rusty

2019-08-14 20:04

administrator   ~0054351

1) Normally the hash marks associated with a slider cross the middle of the slider or are on both sides of the slider (here it looks like they're misaligned). So yes, it should probably be fixed.

michal

2019-08-15 09:41

developer   ~0054358

Fixed in build 2192, used centered ticks.

Ludek

2019-08-15 21:08

developer   ~0054365

Last edited: 2019-08-15 22:04

View 2 revisions

The ticks looks ugly IMO, wouldn't it be better to use the material slider control?
https://material.io/design/components/sliders.html

=> Fixed in 2192

michal

2019-08-16 13:40

developer   ~0054367

I agree, after slightly adjusted styling ticks are not needed there, removed.

peke

2019-08-17 00:59

developer   ~0054382

Verified 1, 2 in 2192

I wonder if using Discrete Slider like in Ludek Link at post 0015880:0054365 would be even better? eg. it would show user Slider position that can be very useful especially in Touch Mode.

michal

2019-08-19 13:41

developer   ~0054388

We already display volume slider value in toast, in all skins.

rusty

2019-08-29 01:58

administrator   ~0054442

Verified 2193.