View Issue Details

IDProjectCategoryView StatusLast Update
0015813MediaMonkey 5Main Panelpublic2019-08-06 12:49
Reporterlowlander 
PriorityurgentSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015813: Find More From Same: Slow Behavior
Description1. Using Find More From Same > Album took over a minute.

2. Find More From Same shows Continuous -> Loading... Steps: Right click on Now playing Track -> Find More From Same -> Album -> Wait till it show result -> Right click on same Now playing Track -> Find More From Same -> Loading... Shows endlessly Workaround: Right click on any other Now Playing Track and then Right click back on one that Showed Loading ... and it shows correctly FMFS Menu.
TagsNo tags attached.
Fixed in build2191

Relationships

related to 0014847 closedLudek Find more from same album/artist is terribly slow (regression) 

Activities

lowlander

2019-06-28 22:41

developer  

FMFS Album slow.zip (1,439,221 bytes)

lowlander

2019-06-28 22:45

developer   ~0054008

Type to jump to an Album in the expanded Album node is also very slow to respond

Ludek

2019-07-02 20:38

developer   ~0054074

Last edited: 2019-07-02 20:39

View 2 revisions

In the log I see that task nodeHandlers.albums.getChildren took more than 228 seconds!
So just getting the list of album takes incredible long time on your database.

Could you please zip your database and upload it somewhere to analyze?

peke

2019-07-02 23:06

developer   ~0054078

I am, not being able to replicate such long delay but, I have noticed sporadically show behavior of FMFS

Ludek

2019-07-23 12:33

developer   ~0054194

Last edited: 2019-07-24 18:45

View 8 revisions

I was able to replicate this on LowLander's database, the key was to hover over Find more from same > Playlist submenu item. In that case it started task to load the playlists to which the track belong (which takes incredibly long time on LL's database due to complexity of his auto-playlists) and this task was not properly canceled when you stop hovering over this Playlist menu item.

=> Fixed in 2187 together with some further performance issues that I am observing on LL's database.

Remaining issues (with 'showAllNodes' extension installed):
- FMFS artist takes more than 8 seconds on LL's db and UI thread seems frozen during that time
- albums node expanded in the media tree: Typing to jump to an album is slow to respond (up to several seconds) => fixed in 2187

Ludek

2019-08-06 12:48

developer   ~0054275

Last edited: 2019-08-06 12:49

View 2 revisions

Fixed in 2191.

Working with thousands of subnodes (and FMFS) is much faster now.