View Issue Details

IDProjectCategoryView StatusLast Update
0015792MediaMonkey 5Main Panelpublic2019-07-23 00:33
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015792: Regressions in Arts&Details panel
DescriptionThere are various issues/regression with the A&D panel reported:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94646

1) The View menu item for the "Now Playing" panel is still called "Playing" .... is confusing because there is a "Playing" panel, but the "Playing" View menu item does not control that panel.
=> this is tracked as 0015758

2) The [u]config dbox[/u] for the hamburger menu for Selected Layout|Advanced is displayed full screen.

3) Clicking on the album art in the Selected pane, shows a dbox with full size album art. ... The dbox has a minimise button. That button minimises just the album art dbox. ... It goes down to the bottom left (see diagram) ... It cannot be restored ... MM is now frozen because the dbox is modal.
[url]https://www.dropbox.com/s/hq051nrsxa40urb/dbox%20minimises%20but%20can%20be%20restored.png?dl=0[/url]

4) Panel resize cursor is sometimes unavailable
Steps:
[list]Setup the rhs panel to show Art&Details and the Now Playing panel[/list]
[list]Close the rhs panel[/list]
[list]close MM5[/list]
[list]restart MM5[/list]
[list]turn the rhs panel on again[/list]

There is no hotspot allowing panel resize (ie. the resize cursor indicated in diagram is not available)
Open the panel's Layout|Advanced config menu ... just press enter ==> the hotspot is now available ... the panel cannot be resized
[url]https://www.dropbox.com/s/0kz2x86snfbybwx/resize%20cursor%20missing.png?dl=0[/url]

5) The "Selected" panel has an edit mode ... I tried it ... it only allows single character edits .... ie. type 1 character ... MM seizes the character and does the edit immediately ... cursor position moves from the "selection" panel to the centre panel ... if you entered multiple characters into your edit, everything beyond the 1st character is seized by the main panel's contextual search facility, and you are navigated away from the item that you are trying to edit
[url]https://www.dropbox.com/s/fb2866eokt6qrdl/edit%20mode%20in%20Selected%20panel.png?dl=0[/url]
TagsNo tags attached.
Fixed in build2184

Relationships

related to 0015797 closedmichal Column filter height cannot be changed - regression 
related to 0015758 closedpetr Functionality of the Preview Window unclear (due to Title bar heading?) 
related to 0015830 closedLudek Editing in preview window can cause change in track selection 
related to 0015838 closedpetr Maximizing and closing dialogs causes various anomalies 

Activities

Ludek

2019-06-26 10:25

developer   ~0053982

Last edited: 2019-06-26 12:08

View 4 revisions

1) is tracked as 0015758

2) This must be a regression related to the shared dialog windows, in the artWindow.js (line 994) there is 'width: 300', but MM5 is ignoring the specified width and shows the dialog as wide as the main window.
Workaround seems to be to specify non-zero value for left
Used the workaround in 2184 and assigned to Petr for the proper fix

4) is fixed by 0015797

5) is fixed in 2184

2&3 assigned to Petr

petr

2019-06-26 14:53

developer   ~0053983

Fixed

Ludek

2019-06-26 23:06

developer   ~0053990

Last edited: 2019-06-26 23:13

View 3 revisions

3) I am still seeing this issue with any other dialog that can be minimized (Convert Format, Auto-organize, Auto-tag from filename, Choose fields, ...):
https://www.dropbox.com/s/wu1ma463ihphek5/Screenshot%202019-06-27%2001.11.29.png?dl=0

These dialogs can be restored by clicking the MM taskbar icon, but upon restoring the columns width in the listview is shrinked to the minimal width:
https://www.dropbox.com/s/gsy0802ezs3n0g5/Screenshot%202019-06-27%2001.10.09.png?dl=0

rusty

2019-07-23 00:22

administrator   ~0054190

Last edited: 2019-07-23 00:28

View 2 revisions

3) is still broken, though in a slightly different manner:
1 Click album art in Preview:Selected
2 Press 'Maximize' to cause the AA to fill the screen
3 Press 'Close' to close the AA
4 Click album art in Preview:Selected
-->It opens but without window borders so it can't be resized!

Note that this issue applies to other dialogs that Ludek mentioned as well (Convert Format, Auto-organize, Auto-tag from filename, Choose fields, ...). This issue seems to be particularly problematic since triggering the problem in one dialog (conversion) causes the problem to appear in other dialogs (Properties).

note: I'm closing this bug and moving this to a new issue since it's really not just a Now Playing bug.

rusty

2019-07-23 00:29

administrator   ~0054191

Verified 2186.